Subject: [alpine-devel] "rc is deprecated" warnings on fresh 3.4 install

From: Alba Pompeo <[email-masked]>
Date: Mon, 6 Jun 2016 13:31:10 -0300

I've just installed Alpine 3.4 (fresh) and no other packages.
Upong shutdown, i prints this message (twice).
"rc is deprecated, please use openrc instead."

Ciao!

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Alba Pompeo <[email-masked]>
Date: Mon, 6 Jun 2016 19:11:02 -0300

The solution is to change line 22 from ::shutdown:/sbin/rc shutdown
to   ::shutdown:/sbin/openrc shutdown
https://github.com/JuliaLang/julia/issues/16792

Ciao!

---

---

From: Alba Pompeo <[email-masked]>
Date: Tue, 7 Jun 2016 14:01:35 -0300

Fixed on http://git.alpinelinux.org/cgit/aports/commit/?id=48a669f23fbe328c072c2d8783cce95d125c470b
It would be good if this fix was also added to the 3.4 stable branch.
Thanks.

---