~alpine/devel

7 4

[alpine-devel] mpv is broken

Alba Pompeo
Details
Message ID
<CAJDAfTBHukJ9KD0rWLb7=s9-ix3qQ5jBW6Gz+d=xCFecV4eVTg@mail.gmail.com>
Sender timestamp
1453344872
DKIM signature
missing
Download raw message
mpv is broken on latest release v3.3.1
 (+) Video --vid=1 (*) (h264)
 (+) Audio --aid=1 --alang=und (*) (aac)
libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
[vo/opengl/x11] X11 error: BadValue (integer parameter out of range
for operation)
[vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 37
[vo/opengl/x11] Error code: 2, request code: 9a, minor code: 3
[vo/opengl/x11] X11 error: GLXBadContext
[vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: a00003, serial: 38
[vo/opengl/x11] Error code: aa, request code: 9a, minor code: 5
[vo/opengl/x11] X11 error: 0
[vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 38
[vo/opengl/x11] Error code: 0, request code: 9a, minor code: 1a
[vo/opengl] Could not set GLX context!

I looked on the archives and found a hint, that I should addgroup me
to video. But I already did that long before and the issue remains.

Ciao


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Isaac Dunham
Details
Message ID
<20160121032336.GA2997@newbook>
In-Reply-To
<CAJDAfTBHukJ9KD0rWLb7=s9-ix3qQ5jBW6Gz+d=xCFecV4eVTg@mail.gmail.com> (view parent)
Sender timestamp
1453346617
DKIM signature
missing
Download raw message
On Thu, Jan 21, 2016 at 12:54:32AM -0200, Alba Pompeo wrote:
> mpv is broken on latest release v3.3.1
>  (+) Video --vid=1 (*) (h264)
>  (+) Audio --aid=1 --alang=und (*) (aac)
> libGL error: failed to open drm device: Permission denied
> libGL error: failed to load driver: i965
> libGL error: unable to load driver: swrast_dri.so
> libGL error: failed to load driver: swrast
> [vo/opengl/x11] X11 error: BadValue (integer parameter out of range
> for operation)
> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 37
> [vo/opengl/x11] Error code: 2, request code: 9a, minor code: 3
> [vo/opengl/x11] X11 error: GLXBadContext
> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: a00003, serial: 38
> [vo/opengl/x11] Error code: aa, request code: 9a, minor code: 5
> [vo/opengl/x11] X11 error: 0
> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 38
> [vo/opengl/x11] Error code: 0, request code: 9a, minor code: 1a
> [vo/opengl] Could not set GLX context!
> 
> I looked on the archives and found a hint, that I should addgroup me
> to video. But I already did that long before and the issue remains.

ls -l /dev/dri/

I suspect that for unknown reasons, eudev isn't setting the proper group.

Currently mdev isn't either...Ah, mdev is only looking for the old
directory-free pathnames (card0 instead of dri/card0).
Adding this to mdev.conf should fix it for those who don't need eudev:
dri/*	root:video 0660

There may be a similar oversight in the eudev rules, or there might not.

HTH,
Isaac Dunham


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Alba Pompeo
Details
Message ID
<CAJDAfTC_Qej4eZ-=Q034K4KYVmhSsx2-5J9FFfraj9-DoxJcCQ@mail.gmail.com>
In-Reply-To
<20160121032336.GA2997@newbook> (view parent)
Sender timestamp
1455114988
DKIM signature
missing
Download raw message
Chromium also have the same error.
And I am sure I'm on the video group.
libGL error: failed to open drm device: Permission denied

On Thu, Jan 21, 2016 at 1:23 AM, Isaac Dunham <ibid.ag@gmail.com> wrote:
> On Thu, Jan 21, 2016 at 12:54:32AM -0200, Alba Pompeo wrote:
>> mpv is broken on latest release v3.3.1
>>  (+) Video --vid=1 (*) (h264)
>>  (+) Audio --aid=1 --alang=und (*) (aac)
>> libGL error: failed to open drm device: Permission denied
>> libGL error: failed to load driver: i965
>> libGL error: unable to load driver: swrast_dri.so
>> libGL error: failed to load driver: swrast
>> [vo/opengl/x11] X11 error: BadValue (integer parameter out of range
>> for operation)
>> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 37
>> [vo/opengl/x11] Error code: 2, request code: 9a, minor code: 3
>> [vo/opengl/x11] X11 error: GLXBadContext
>> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: a00003, serial: 38
>> [vo/opengl/x11] Error code: aa, request code: 9a, minor code: 5
>> [vo/opengl/x11] X11 error: 0
>> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 38
>> [vo/opengl/x11] Error code: 0, request code: 9a, minor code: 1a
>> [vo/opengl] Could not set GLX context!
>>
>> I looked on the archives and found a hint, that I should addgroup me
>> to video. But I already did that long before and the issue remains.
>
> ls -l /dev/dri/
>
> I suspect that for unknown reasons, eudev isn't setting the proper group.
>
> Currently mdev isn't either...Ah, mdev is only looking for the old
> directory-free pathnames (card0 instead of dri/card0).
> Adding this to mdev.conf should fix it for those who don't need eudev:
> dri/*   root:video 0660
>
> There may be a similar oversight in the eudev rules, or there might not.
>
> HTH,
> Isaac Dunham


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Shiz
Details
Message ID
<D20D6C05-FD8D-4897-BB5A-61EF4CF8854D@shiz.me>
In-Reply-To
<CAJDAfTC_Qej4eZ-=Q034K4KYVmhSsx2-5J9FFfraj9-DoxJcCQ@mail.gmail.com> (view parent)
Sender timestamp
1455119721
DKIM signature
missing
Download raw message
> On 10 Feb 2016, at 15:36, Alba Pompeo <albapompeo@gmail.com> wrote:
> 
> Chromium also have the same error.
> And I am sure I'm on the video group.
> libGL error: failed to open drm device: Permission denied

I’ve been having the same issue with mdev, it somehow failing to set the
/dev/dri/* permissions properly despite configuration to the opposite.

Regardless, su -c 'chown -R root:video /dev/dri' fixes the issue, until you reboot.

- Shiz
Isaac Dunham
Details
Message ID
<20160211072344.GA2546@newbook>
In-Reply-To
<D20D6C05-FD8D-4897-BB5A-61EF4CF8854D@shiz.me> (view parent)
Sender timestamp
1455175425
DKIM signature
missing
Download raw message
On Wed, Feb 10, 2016 at 04:55:21PM +0100, Shiz wrote:
> 
> > On 10 Feb 2016, at 15:36, Alba Pompeo <albapompeo@gmail.com> wrote:
> > 
> > Chromium also have the same error.
> > And I am sure I'm on the video group.
> > libGL error: failed to open drm device: Permission denied
> 
> I’ve been having the same issue with mdev, it somehow failing to set the
> /dev/dri/* permissions properly despite configuration to the opposite.
> 
> Regardless, su -c 'chown -R root:video /dev/dri' fixes the issue, until you reboot.

On my system (uses mdev), this line in mdev.conf solved it:
dri/.*	root:video 0660

If you have current busybox-initscripts from edge, this line is in
/etc/mdev.conf as packaged -- or /etc/mdev.conf.apk-new if you've edited
the config file.


If you are using eudev, THIS CANNOT HELP.

eudev uses its own rules, which apparently might have a similar issue
(ie, matching the regex dri/.* should be used instead of moving to dri/).
I am not an expert in (e)udev.

I do not recommend trying mdev-with-X on non-experimental systems.
If you want to try using mdev with X:
- disable X autostarting
- enable mdev, disable eudev
- apk add mdev-like-a-boss-xorg (and xf86-input-synaptics for laptops)
- reboot (so that you use the mdev-prepared /dev, rather than thinking
 it's working because of a stale udev-prepared dir).
- start X
- check that mouse and keyboard work


Thanks,
Isaac Dunham



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Alba Pompeo
Details
Message ID
<CAJDAfTCMRL659AjAVxhYa=kcBGfGFJQ-xnRUVChBVX8cXLwY+w@mail.gmail.com>
In-Reply-To
<20160211072344.GA2546@newbook> (view parent)
Sender timestamp
1460539865
DKIM signature
missing
Download raw message
It has passed 3 months and it's still not fixed.
I don't have root access in all my systems and it bothers me to be
unable to use mpv in those cases.
Can we please have this fixed?
Thanks.


On Thu, Feb 11, 2016 at 5:23 AM, Isaac Dunham <ibid.ag@gmail.com> wrote:
> On Wed, Feb 10, 2016 at 04:55:21PM +0100, Shiz wrote:
>>
>> > On 10 Feb 2016, at 15:36, Alba Pompeo <albapompeo@gmail.com> wrote:
>> >
>> > Chromium also have the same error.
>> > And I am sure I'm on the video group.
>> > libGL error: failed to open drm device: Permission denied
>>
>> I’ve been having the same issue with mdev, it somehow failing to set the
>> /dev/dri/* permissions properly despite configuration to the opposite.
>>
>> Regardless, su -c 'chown -R root:video /dev/dri' fixes the issue, until you reboot.
>
> On my system (uses mdev), this line in mdev.conf solved it:
> dri/.*  root:video 0660
>
> If you have current busybox-initscripts from edge, this line is in
> /etc/mdev.conf as packaged -- or /etc/mdev.conf.apk-new if you've edited
> the config file.
>
>
> If you are using eudev, THIS CANNOT HELP.
>
> eudev uses its own rules, which apparently might have a similar issue
> (ie, matching the regex dri/.* should be used instead of moving to dri/).
> I am not an expert in (e)udev.
>
> I do not recommend trying mdev-with-X on non-experimental systems.
> If you want to try using mdev with X:
> - disable X autostarting
> - enable mdev, disable eudev
> - apk add mdev-like-a-boss-xorg (and xf86-input-synaptics for laptops)
> - reboot (so that you use the mdev-prepared /dev, rather than thinking
>  it's working because of a stale udev-prepared dir).
> - start X
> - check that mouse and keyboard work
>
>
> Thanks,
> Isaac Dunham
>


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Alba Pompeo
Details
Message ID
<CAJDAfTCgpAHMNEx1v9FbgeADFtvOq_r1EgFvLt0iCZ64fe7ptA@mail.gmail.com>
In-Reply-To
<20160413135650.7bfc1709@ncopa-desktop.alpinelinux.org> (view parent)
Sender timestamp
1460560748
DKIM signature
missing
Download raw message
Thanks, it's fixed.

On Wed, Apr 13, 2016 at 8:56 AM, Natanael Copa <ncopa@alpinelinux.org> wrote:
> On Wed, 13 Apr 2016 06:31:05 -0300
> Alba Pompeo <albapompeo@gmail.com> wrote:
>
>> It has passed 3 months and it's still not fixed.
>> I don't have root access in all my systems and it bothers me to be
>> unable to use mpv in those cases.
>> Can we please have this fixed?
>> Thanks.
>
> I believe this fixed it (in edge):
>
> http://git.alpinelinux.org/cgit/aports/commit/?id=61254e78ff3679e7de3f31d5a65378af50706371
>
>
> I have now cherry-picked it to 3.3-stable
>
> -nc


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Natanael Copa
Details
Message ID
<20160413135650.7bfc1709@ncopa-desktop.alpinelinux.org>
In-Reply-To
<CAJDAfTCMRL659AjAVxhYa=kcBGfGFJQ-xnRUVChBVX8cXLwY+w@mail.gmail.com> (view parent)
Sender timestamp
1460548610
DKIM signature
missing
Download raw message
On Wed, 13 Apr 2016 06:31:05 -0300
Alba Pompeo <albapompeo@gmail.com> wrote:

> It has passed 3 months and it's still not fixed.
> I don't have root access in all my systems and it bothers me to be
> unable to use mpv in those cases.
> Can we please have this fixed?
> Thanks.

I believe this fixed it (in edge):

http://git.alpinelinux.org/cgit/aports/commit/?id=61254e78ff3679e7de3f31d5a65378af50706371


I have now cherry-picked it to 3.3-stable

-nc


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---