Subject: [alpine-devel] apk failed to update package?

From: Alba Pompeo <[email-masked]>
Date: Tue, 12 Jul 2016 21:54:07 -0300

Hello.

I did 'apk update && apk upgrade'
It updated julia-dev and julia-doc, but not julia.
I had to uninstall julia and then install it again to get the new version.
Weird.
Has anyone else had similar issues?

Ciao!

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Wed, 13 Jul 2016 08:24:34 +0300

On Tue, 12 Jul 2016 21:54:07 -0300
Alba Pompeo <[email-masked]> wrote:

> I had to uninstall julia and then install it again to get the new
> version. Weird.

Did you install julia by naming the .apk file? If so, apk prefers
that .apk file until you reset dependencies with "upgrade -a".

/Timo

---