Subject: [alpine-devel] R compiled on Alpine - need more testers

From: Alba Pompeo <[email-masked]>
Date: Mon, 22 Feb 2016 08:45:20 -0300

I successfully compiled R, and it worked without problems except for a
minor timezone issue at the very very end of make check-all that's
already been reported to the R developers. This was on a x64 system
running Alpine 3.3.1 stable.
But we have a problem! Isaac Dunham also compiled R (on his x86 Alpine
edge system) and got lots of major errors on make check. "*no*
convergence" errors, which makes R untrustworthy.
So what we ask now is for those interested in R to compile it and
report back any errors they have.
Here's how we are doing it.
    svn checkout https://svn.r-project.org/R/trunk/
    cd ./trunk
    aclocal -I m4 && autoconf
    tools/rsync-recommended
    cd ..
    mkdir build
    cd build
    ../trunk/configure
    make
If it compiles okay, then run "make check-all" and report the errors you have.

Ciao.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Shiz <[email-masked]>
Date: Mon, 22 Feb 2016 23:40:56 +0100

> On 22 Feb 2016, at 12:45, Alba Pompeo <[email-masked]> wrote:
> 

I got a few timezone issues, a Unicode issue that may be caused by not setting
$LANG/$LC_ALL on the account I tested it with, and a few misc math things.

Machine: Linux xenon 4.1.6-249 #1 SMP Mon Aug 31 12:34:47 UTC 2015 armv7l Linux
OS: Alpine Edge
CPU/Arch: Marvell Armada 370/XP (ARMv7)
R revision tested: 70206

The test log is attached.

- Shiz

---

From: Alba Pompeo <[email-masked]>
Date: Wed, 24 Feb 2016 12:59:27 -0300

The timezones issues are the same I had and the R devs are aware of it
(but it doesn't look like they will fix it anytime soon).
The other errors also look small.
I think it's safe to package R for x64 and ARM so far. It failed on
Isaac's system though, which is x86.
Anyone  interested in packaging R?
Also sorry for the late reply, your email went to my spam folder for
some reason.

Ciao

---