Subject: [alpine-devel] [PATCH] main/ruby: Added dependency on ruby-gems.

From: Quora Dodrill <[email-masked]>
Date: Mon, 8 Jul 2013 14:57:12 -0700

>From 4aa434f8b8cf208ac5087791094aa45412128e95 Mon Sep 17 00:00:00 2001

Instllaing ruby without ruby-gems makes ruby fail with the following error
when trying to run ruby without a file to interpret.

[quora@genesect:~] > ruby
/usr/lib/ruby/2.0.0/rubygems.rb:15:in `require': cannot load such file --
rubygems/compatibility (LoadError)
        from /usr/lib/ruby/2.0.0/rubygems.rb:15:in `<top (required)>'
        from <internal:gem_prelude>:1:in `require'
        from <internal:gem_prelude>:1:in `<compiled>'

Installing ruby-gems fixes this and makes ruby programs run as they should.
---
 main/ruby/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index 9da0f6d..df63972 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -11,7 +11,7 @@ pkgdesc="An object-oriented language for quick and easy
programming"
 url="http://www.ruby-lang.org/en/"
 arch="all"
 license="Ruby"
-depends=""
+depends="ruby-gems"
 makedepends="zlib-dev openssl-dev libiconv-dev gdbm-dev db-dev readline-dev
        libffi-dev coreutils yaml-dev autoconf"
 subpackages="$pkgname-doc $pkgname-dev $pkgname-irb $pkgname-gems \
-- 
1.8.3.2

---

From: Natanael Copa <[email-masked]>
Date: Tue, 9 Jul 2013 15:33:02 +0200

On Mon, 8 Jul 2013 14:57:12 -0700

>  subpackages="$pkgname-doc $pkgname-dev $pkgname-irb $pkgname-gems \

The patch didn't apply.

Also, the ruby-gems package depends on ruby so this would introduce a
circular dependency.

I wonder if we should just  drop the ruby-gems subpackage and let
ruby-libs ship the libs and 'ruby' package ship the /usr/bin/gems file.
That seems to be the most sane way to solve this.

What do you think?

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---