Subject: Fwd: [alpine-devel] Alpine 3.0.0 Release candidate 1 is out

From: Chris Spillane <[email-masked]>
Date: Fri, 23 May 2014 09:58:03 +0100

Ooos, forgot to 'reply all'

---------- Forwarded message ----------
From: Chris Spillane <[email-masked]>
Date: 23 May 2014 09:09
Subject: Re: [alpine-devel] Alpine 3.0.0 Release candidate 1 is out
To: Timo Teras <[email-masked]>

Hello Timo,

I've not tried the mini versions, only
"alpine-3.0.0_rc1-x86_64.iso<http://nl.alpinelinux.org/alpine/v3.0/releases/x86_64/alpine-3.0.0_rc1-x86_64.iso>"
and "alpine-3.0.0_rc1-x86.iso<http://nl.alpinelinux.org/alpine/v3.0/releases/x86/alpine-3.0.0_rc1-x86.iso>"
which both appear to have the issue.  I can probably find the time today to
test the mini releases if you like?

Thanks!

On 23 May 2014 06:42, Timo Teras <[email-masked]> wrote:

> On Thu, 22 May 2014 19:01:19 +0300
> Timo Teräs <[email-masked]> wrote:
>
> > On Thu May 22 2014 06:04:57 PM EEST, Natanael Copa
> > <[email-masked]> wrote:
> >
> > > On Thu, 22 May 2014 15:34:46 +0100
> > > Chris Spillane <[email-masked]> wrote:
> > >
> > > > me@someserver:~# setup-apkrepos
> > > > ERROR: unsatisfiable constraints:
> > > > .setup-apkrepos-0
> > > > masked in: cache
> > > > satisfies: world[.setup-apkrepos]
> > > > alpine-mirrors (missing):
> > > > required by:
> > > > r) Add random from the above list
> > > > f) Detect and add fastest mirror from the above list
> > > > e) Edit /etc/apk/repositories with text editor
> > > >
> > > > Enter mirror number (1-0) or URL to add (or r/f/e/done) [f]:
> > > > ====
> > > >
> > > > This is a sys install.   So far everything else works like a
> > > > dream :)
> >
> > Urgh. This is probably caused be the other fix I did for apk-tools.
> >
> > I wonder why abuild works. I'll fix this today/tomorrow.
>
> False alarm. I misread the error message. In fact, what I thought that
> broke, is covered in test suite :)
>
> This just likely that 'alpine-mirrors' is not included in the .iso
> image.
>
> Chris, which variant of the .iso you tried? The regular one or the
> 'mini' variant?
>
> - Timo
>

-- 
Chris Spillane

---

From: Chris Spillane <[email-masked]>
Date: Fri, 23 May 2014 12:59:26 +0100

Hello again,

just tested again with the mini ISO's
http://nl.alpinelinux.org/alpine/v3.0/releases/x86/alpine-mini-3.0.0_rc1-x86.isoand
http://nl.alpinelinux.org/alpine/v3.0/releases/x86_64/alpine-mini-3.0.0_rc1-x86_64.isoand
get the same issue.  I think you're right in saying the list is
missing
from the ISO.
I'm working on VirtualBox/VMware Virtual Machines but that shouldn't matter
- booting from ISO like on a real machine.

Workaround is simple of course, just do:
# echo "http://nl.alpinelinux.org/alpine/v3.0/main" > /etc/apk/repositories

but for the ISO, having the mirror list in place is recommended.

Thanks,

Chris

On 23 May 2014 09:58, Chris Spillane <[email-masked]> wrote:

> I've not tried the mini versions, only "alpine-3.0.0_rc1-x86_64.iso<http://nl.alpinelinux.org/alpine/v3.0/releases/x86_64/alpine-3.0.0_rc1-x86_64.iso>"

-- 
Chris Spillane