Subject: [alpine-devel] gradm - "/dev/grsec" file not found

From: systmkor <[email-masked]>
Date: Wed, 15 Oct 2014 14:43:12 -0700

I have installed gradm and running version 3.0 of alpine linux with the grsec kernel. When I try running “gradm -P” I get error messages

Could not open /dev/grsec.
open: No such file or directory

I have looked around in other distros were this is supposed to be created or what the proper way of creating that specific device is but I haven’t found any useful information.

systmkor

---

From: Natanael Copa <[email-masked]>
Date: Thu, 16 Oct 2014 17:05:41 +0200

On Wed, 15 Oct 2014 14:43:12 -0700
systmkor <[email-masked]> wrote:

> I have installed gradm and running version 3.0 of alpine linux with the grsec kernel. When I try running *gradm -P* I get error messages
> 
> I have looked around in other distros were this is supposed to be created or what the proper way of creating that specific device is but I haven*t found any useful information.
> 
> systmkor
> 

i have enabled RBAC in kernel again with 3.14.20-r2 and later.

thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: systmkor <[email-masked]>
Date: Thu, 16 Oct 2014 15:44:16 -0700

Thank you. I attached the kernel configuration I compiled and got working on a Linode instance I am running. I am planning on making a more detailed configuration related grsec with detailed reasons why certain flags should be turned on or off. 

systmkor