Subject: Steps building Alpine Xen ISO?

From: "Dr. Lonnie Cumberland, PhD" <[email-masked]>
Date: Sun, 18 Feb 2024 11:24:33 -0500

Hello All,

I have just started working with the Alpine Xen distro as I need a 
minimal size Xen that runs in RAM as a starting point on a project.

Being new to Alpine and have mostly used Ubuntu, CentOS, and a few 
others, I have a bit of experience in the Linux world, but just not a 
lot with Alpine but must say that I truly love the minimalist approach.

With that in mind, I would like to know if there is a developers link to 
building the Alpine Xen ISO from scratch or if someone might have the 
steps available that I could get and give it a try?

Any help would be greatly appreciated and have a great day,
Lonnie

---

From: Leonardo Arena <[email-masked]>
Date: Sun, 18 Feb 2024 17:31:17 +0100

Hi,

the already built Alpine XEN ISO does not suit your needs?

https://dl-cdn.alpinelinux.org/alpine/v3.19/releases/x86_64/alpine-xen-3.19.1-x86_64.iso

Cheers,
leo

On Sun, Feb 18, 2024 at 5:25 PM Dr. Lonnie Cumberland, PhD <
[email-masked]> wrote:

> Hello All,
>
> I have just started working with the Alpine Xen distro as I need a minimal
> size Xen that runs in RAM as a starting point on a project.
>
> Being new to Alpine and have mostly used Ubuntu, CentOS, and a few others,
> I have a bit of experience in the Linux world, but just not a lot with
> Alpine but must say that I truly love the minimalist approach.
>
> building the Alpine Xen ISO from scratch or if someone might have the steps
> available that I could get and give it a try?
>

---

From: "Dr. Lonnie Cumberland, PhD" <[email-masked]>
Date: Sun, 18 Feb 2024 11:37:10 -0500

Hi Leo,

Actually, I am working on a modified Xen for security and 
fault-tolerance improvements using ideas from Xoar, and Dom0Less peer 
papers and want to build out a new Xen ISO based upon Alpine for various 
testing.

With that in mind, I need to be able to easily build that ISO from scratch.

Thanks
Lonnie

On 2/18/2024 11:31 AM, Leonardo Arena wrote:
> On Sun, Feb 18, 2024 at 5:25 PM Dr. Lonnie Cumberland, PhD 
> <[email-masked]> wrote:
>
>     Hello All,
>
>     others, I have a bit of experience in the Linux world, but just
>     not a lot with Alpine but must say that I truly love the
>     minimalist approach.
>
>     With that in mind, I would like to know if there is a developers
>     link to building the Alpine Xen ISO from scratch or if someone
>     might have the steps available that I could get and give it a try?
>

---

From: Leonardo <[email-masked]>
Date: Sun, 18 Feb 2024 17:53:21 +0100

It's a long time I don't build a custom ISO, so I dunno if things have 
changed, but this is a starting point:

https://wiki.alpinelinux.org/wiki/How_to_make_a_custom_ISO_image

leo

On 18/02/24 17:37, Dr. Lonnie Cumberland, PhD wrote:
> papers and want to build out a new Xen ISO based upon Alpine for 
> various testing.
>
>>     I have just started working with the Alpine Xen distro as I need
>>     a minimal size Xen that runs in RAM as a starting point on a project.
>>
>>     Being new to Alpine and have mostly used Ubuntu, CentOS, and a
>>     few others, I have a bit of experience in the Linux world, but
>>     just not a lot with Alpine but must say that I truly love the
>>     minimalist approach.
>>

---

From: "Dr. Lonnie Cumberland, PhD" <[email-masked]>
Date: Sun, 18 Feb 2024 12:00:43 -0500

Thanks Leo,

I'll start looking around at that point.

Not sure if the actual Alpine developers are on this list, but I do see 
that the latest releases are:

Current Alpine Version 3.19.1 (Released Jan 26, 2024)

Maybe they have an automated script or something.

Thanks again and I will look into it more as well.
Cheers,
Lonnie

---

From: "Dr. Lonnie Cumberland, PhD" <[email-masked]>
Date: Sun, 18 Feb 2024 12:05:47 -0500

Hi Leo,

I think that I may have found it in the "Aports/scripts" directory

https://github.com/alpinelinux/aports/tree/master/scripts

This seems to be it but an still investigating more.

Cheers,
Lonnie