Subject: [alpine-devel] ARM and U-boot

From: Nicolas <[email-masked]>
Date: Fri, 20 Feb 2015 13:31:35 +0100

Hello to all, 

The Alpine release for RaspberryPi works like a charm on this little ARM
machine. 
At work we recently purchased a Cubox machine
http://www.solid-run.com/products/cubox-i-mini-computer/

I was wondering if someone already tried Alpine on this hardware. 
It seems to be armhf like the rapsberry pi , but the bootloader uses
U-Boot like many other arm machines. 

Maybe making U-boot work with the Alpine build system would be another
great beginning for the ARM branch of Alpine ? 

Regards, 

Nicolas.

---

From: Orion <[email-masked]>
Date: Tue, 3 Mar 2015 21:24:35 -0800

On Fri, 20 Feb 2015 13:31:35 +0100

> great beginning for the ARM branch of Alpine ? 

I fully support this. I am planning on using U-Boot with Alpine for for
an embedded systems project I'm working on. I should have replied ages
ago. Hit me up, I will gladly work with you on this.

-- 
keybase.io/systmkor

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Nathan Angelacos <[email-masked]>
Date: Fri, 20 Feb 2015 07:57:03 -0500

Hi Nicolas,

On 02/20/2015 07:31 AM, Nicolas wrote:
>
> Maybe making U-boot work with the Alpine build system would be another great beginning for the ARM branch of Alpine ?
>

There's some work on this, but it looks like its in its infancy stages. 
  See for example:

http://lists.alpinelinux.org/alpine-devel/4674.html

---

---

From: Nicolas <[email-masked]>
Date: Fri, 20 Feb 2015 14:54:58 +0100

Le 2015-02-20 13:57, Nathan Angelacos a écrit :
> There's some work on this, but it looks like its in its infancy
> stages.  See for example:
> 
> 

Thank you very much Nathan.
I'll try to test or adapt this.

---