Subject: [alpine-devel] abuild -f should verify checksums, right?

From: Oliver Smith <[email-masked]>
Date: Sat, 09 Dec 2017 01:24:00 +0000

Hello Alpine devs,

I have noted that abuild does not verify the checksums in the APKBUILD when the -f (force) flag gets passed. kaniini said "I think this is intentional" and asked me to write here.

So is this intentional (and if so, for which reasons)?
See the full bug report below.

Best regards,
Olvier

-------- Forwarded Message --------
Subject: [Alpine Linux - Bug #8257] (New) abuild -f doesn't verify checksums
Date: Thu, 07 Dec 2017 21:17:17 +0000
From: [email-masked]

Issue #8257 has been reported by Oliver Smith.

----------------------------------------
Bug #8257: abuild -f doesn't verify checksums
https://bugs.alpinelinux.org/issues/8257

* Author: Oliver Smith
* Status: New
* Priority: High
* Assignee: 
* Category: Toolchain
* Target version: 3.7.1
* Affected versions: 3.7.0, 3.7.1, 3.8.0
----------------------------------------
h2. Versions
abuild-3.1.0-r3

h2. What happens
Build an aport with -f does not verify the checksums.

h2. What I expected
I've expected it to verify them, since the help sounds like it will build again if a package already exists. But it's unexpected to me, that the checksums don't get verified.

abuild -h says:
<pre>
-f  Force specified cmd, even if they are already done
</pre>

h2. How to reproduce
<pre>
mkdir hello-world
cd hello-world
wget https://raw.githubusercontent.com/postmarketOS/pmbootstrap/a876a428dde66a334aec8da446df5b23ae35ddf1/aports/main/hello-world/APKBUILD
wget https://raw.githubusercontent.com/postmarketOS/pmbootstrap/a876a428dde66a334aec8da446df5b23ae35ddf1/aports/main/hello-world/Makefile
wget https://raw.githubusercontent.com/postmarketOS/pmbootstrap/a876a428dde66a334aec8da446df5b23ae35ddf1/aports/main/hello-world/main.c
echo "// modification" >> main.c
abuild # checksums get verified
abuild -f # checksums don't get verified!
</pre>

-- 
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: https://bugs.alpinelinux.org/my/account

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: "A. Wilcox" <[email-masked]>
Date: Fri, 8 Dec 2017 22:24:06 -0600

On 08/12/17 19:24, Oliver Smith wrote:
> Hello Alpine devs,
> 
> I have noted that abuild does not verify the checksums in the 
> APKBUILD when the -f (force) flag gets passed. kaniini said "I
> think this is intentional" and asked me to write here.
> 
> So is this intentional (and if so, for which reasons)? See the
> full bug report below.
> 
> Best regards, Olvier

To me: -f means force, which means ignore errors and keep going, which
means checksum errors don't matter.

The help should definitely be written clearer.

This is one reason I am trying to document what abuild does, instead
of what abuild says it will do.  That is also why it is taking me so
long to actually write the manpages.

Best,
- --arw

- -- 
A. Wilcox (awilfox)
Project Lead, Adélie Linux
http://adelielinux.org

---