Subject: [alpine-devel] Alpine 3.5 Python packages missing

From: Janosch Maier <[email-masked]>
Date: Thu, 23 Aug 2018 08:18:12 +0200

Dear Alpiners,

since yesterday, the python3-3.5.6-r0 [1] and python3-dev-3.5.6-r0 [2] are missing in the package repository. The packages appear with this version numbers in the package index but do not exist on the download server.

[1] http://dl-cdn.alpinelinux.org/alpine/v3.5/main/x86_64/python3-3.5.6-r0.apk
[2] http://dl-cdn.alpinelinux.org/alpine/v3.5/main/x86_64/python3-dev-3.5.6-r0.apk

As I am still new to alpine development, I also created a bug report in the bugtracker here: https://bugs.alpinelinux.org/issues/9330

Regards
Janosch

---

From: Fabian Affolter <[email-masked]>
Date: Thu, 23 Aug 2018 11:45:35 +0200

On 08/23/2018 08:18 AM, Janosch Maier wrote:
> since yesterday, the python3-3.5.6-r0 [1] and python3-dev-3.5.6-r0 [2]
> are missing in the package repository. The packages appear with this
> version numbers in the package index but do not exist on the download
> server.

A new build for Python 3 was done yesterday afternoon and there seems be
no errors [1]. At least on mirrors.dotsrc.org [2] are both packages
available. I assume that not all mirrors are synced at the moment.

Kind regards,

Fabian

[1]
http://build.alpinelinux.org/buildlogs/build-3-5-x86_64/main/python3/python3-3.5.6-r0.log
[2] http://mirrors.dotsrc.org/alpine/v3.5/main/x86_64/

---

From: Janosch Maier <[email-masked]>
Date: Fri, 24 Aug 2018 08:05:31 +0200

> available. I assume that not all mirrors are synced at the moment.

If it was just a normal synchronization case, the packages should become available automatically quite fast (I have never experienced delays more than some few hours in that case).
However the python3-dev package is still missing on the server.

Best regards
Janosch