Subject: [alpine-devel] Chronyd blocks boot for ~5s. How can I improve this?

From: 段垚 <[email-masked]>
Date: Wed, 15 Mar 2017 14:50:02 +0800

Hi,

I'm new to Apline and just installed Apline 3.5.2 to hard disk (in 
Virtualbox, x86_64) with default options. During the boot, I note that 
chronyd takes ~5 seconds to start, which I think is too much. How can I 
improve this?

Wireshark shows that there are 3~4 NTP requests sent during the boot 
with a interval ~2s, I think this explains why chronyd takes so much 
time to start. But why can't it do this in background?

I try to start chronyd in command line, it also takes >5s before going 
to background:

# rc-service chronyd stop
  * Stopping chronyd ...
# time chronyd
real    0m 7.37s
user    0m 0.00s
sys    0m 0.00s

However I failed to find an option for command line or configure file to 
change this behavior.

Regards,
Duan, Yao

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Stuart Cardall <[email-masked]>
Date: Wed, 15 Mar 2017 14:08:36 +0000

I noticed this with chronyd too - now I use sntpc with:

SNTPC_INTERVAL="21600"

set in /etc/conf.d/sntpc

Stuart Cardall.

On 03/15/2017 06:50 AM, 段垚 wrote:
> chronyd takes ~5 seconds to start, which I think is too much. How can
> I improve this?
>
> However I failed to find an option for command line or configure file
> to change this behavior.
>
> Regards,
> Duan, Yao
>
>
>
>
> ---

---

From: 段垚 <[email-masked]>
Date: Wed, 15 Mar 2017 23:24:41 +0800

> I noticed this with chronyd too - now I use sntpc with:
Great to know sntp.

I also found that I can workaround this issue by add `--background` 
option to `start-stop-daemon` in `/etc/init.d/chronyd`.
However don't know whether this breaks anything.

>> Virtualbox, x86_64) with default options. During the boot, I note 
>> that chronyd takes ~5 seconds to start, which I think is too much. 
>> How can I improve this?
>>
>> I try to start chronyd in command line, it also takes >5s before 
>> going to background:
>>

---

From: Ivan Tham <[email-masked]>
Date: Thu, 16 Mar 2017 10:26:13 +0800

I didn't notice slowdown with chronyd as I had enable rc_parallel.

But I did notice that I have to wait for tor to finish starting up which took
some time and as well it is the last service to be started on boot.

By the way duan yao, do you use IME in alpine?

---

---

From: 段垚 <[email-masked]>
Date: Thu, 16 Mar 2017 11:28:07 +0800

> some time and as well it is the last service to be started on boot.
Really? I tried rc_parallel but it made little difference for me. Maybe 
because chronyd is the slowest one in my system.
> By the way duan yao, do you use IME in alpine?
What does IME stand for here? If it's Input Method, no.

---