~alpine/devel

2 2

[alpine-devel] apk fetch --recursive broken in >= v3.7

Roger Newman
Details
Message ID
<ecbadd32-8253-3aa1-b8c4-7c3e2fc17172@riseup.net>
Sender timestamp
1512319394
DKIM signature
missing
Download raw message
Hi,

currently I am not able to fetch some packages with there dependencies. Same packages on v3.6 did not have any of this issues.

## Environment:

/ # cat /etc/issue
Welcome to Alpine Linux 3.7
Kernel \r on an \m (\l)

/ # cat /etc/apk/repositories
http://dl-cdn.alpinelinux.org/alpine/v3.7/main
http://dl-cdn.alpinelinux.org/alpine/v3.7/community


## Example:

/ # apk fetch --keys-dir /etc/apk/keys --repositories-file /etc/apk/repositories --output /tmp/ --recursive wget
Downloading musl-1.1.18-r2
Downloading libressl2.6-libssl-2.6.3-r0
Downloading wget-1.19.2-r1
Downloading libressl2.6-libcrypto-2.6.3-r0

/ # apk fetch --keys-dir /etc/apk/keys --repositories-file /etc/apk/repositories --output /tmp/ --recursive curl
curl: unable to select package (or its dependencies)


-- 
Roger Newman


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Dean
Details
Message ID
<tencent_44023A2D2788CDAF828B1349B8364D800106@qq.com>
In-Reply-To
<ecbadd32-8253-3aa1-b8c4-7c3e2fc17172@riseup.net> (view parent)
Sender timestamp
1512404791
DKIM signature
missing
Download raw message
delete  "--recursive"  parameter, then you can fetch successfully!!!  But I don't why..


[root@9ab33cce108a.docker.airdb.io srv]# apk --no-cache fetch --keys-dir /etc/apk/keys --repositories-file /etc/apk/repositories --output /tmp/  curl
fetch http://dl-cdn.alpinelinux.org/alpine/v3.7/main/x86_64/APKINDEX.tar.gz
fetch http://dl-cdn.alpinelinux.org/alpine/v3.7/community/x86_64/APKINDEX.tar.gz
Downloading curl-7.57.0-r0

[root@9ab33cce108a.docker.airdb.io srv]#










------------------ Original ------------------
From:  "Roger Newman";<roger.newman@riseup.net>;
Date:  Mon, Dec 4, 2017 00:43 AM
To:  "Alpine-devel"<alpine-devel@lists.alpinelinux.org>;

Subject:  [alpine-devel] apk fetch --recursive broken in >= v3.7



Hi,

currently I am not able to fetch some packages with there dependencies. Same packages on v3.6 did not have any of this issues.

## Environment:

/ # cat /etc/issue
Welcome to Alpine Linux 3.7
Kernel \r on an \m (\l)

/ # cat /etc/apk/repositories
http://dl-cdn.alpinelinux.org/alpine/v3.7/main
http://dl-cdn.alpinelinux.org/alpine/v3.7/community


## Example:

/ # apk fetch --keys-dir /etc/apk/keys --repositories-file /etc/apk/repositories --output /tmp/ --recursive wget
Downloading musl-1.1.18-r2
Downloading libressl2.6-libssl-2.6.3-r0
Downloading wget-1.19.2-r1
Downloading libressl2.6-libcrypto-2.6.3-r0

/ # apk fetch --keys-dir /etc/apk/keys --repositories-file /etc/apk/repositories --output /tmp/ --recursive curl
curl: unable to select package (or its dependencies)


-- 
Roger Newman


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Timo Teras
Details
Message ID
<20171205182044.11663f18@vostro.domain.com>
In-Reply-To
<ecbadd32-8253-3aa1-b8c4-7c3e2fc17172@riseup.net> (view parent)
Sender timestamp
1512490844
DKIM signature
missing
Download raw message
On Sun, 3 Dec 2017 17:43:14 +0100
Roger Newman <roger.newman@riseup.net> wrote:

> currently I am not able to fetch some packages with there
> dependencies. Same packages on v3.6 did not have any of this issues.

It's because shell dependencies where changes from 'busybox' to virtual
'/bin/sh' dependency, and apk expects one to tell which shell to use.
Add 'busybox' to the list of packages and it should work.

apk is getting better error messages for 'fetch' in future.

Timo



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---