Subject: Building armhf package on x86_64?

From: Mogens Jensen <[email-masked]>
Date: Wed, 23 Mar 2022 12:37:08 +0000

Hi,

I need to build an armhf package on Alpine, but I only have access to x86_64 hardware. The cross-compiler generated by aports/scripts/bootstrap.sh is only for building the base system (can anyone explain why this compiler must not be used for anything else?).

What are my options?

Best regards,
Mogense Jensen

---

From: Milan P. Stanić <[email-masked]>
Date: Wed, 23 Mar 2022 13:52:09 +0100

> I need to build an armhf package on Alpine, but I only have access to x86_64 hardware. The cross-compiler generated by aports/scripts/bootstrap.sh is only for building the base system (can anyone e…

Create armhf lxc on x86_64 with the qemu-arm and qemu-openrc and build
package in this lxc

-- 
Kind regards

---

From: Bart Ribbers <[email-masked]>
Date: Wed, 23 Mar 2022 14:14:41 +0100

Or, use rootbld after setting up the arch you want in binfmt.
Install Qemu for the arch you want (e.g. qemu-riscv64), run "rc-service 
restart qemu-binfmt" and then call "CBUILD=riscv64 abuild rootbld" as you'd 
normally run "abuild -r".