Subject: PKGBUILD conversion script

From: port19 <[email-masked]>
Date: Mon, 28 Aug 2023 09:11:19 +0000

Hi!

I have noticed large similarities between the PKGBUILD format of arch linux and APKGBUILD in alpine.
An awk script converting the two formats may prove beneficial in porting packages.
Of course this has the main limitation of oten differing package names, but that can be disclaimed.
If this sounds like a good idea I can work on an implementation.

Kind Regards,
port19

---

From: Kevin Daudt <[email-masked]>
Date: Mon, 28 Aug 2023 10:34:15 +0000

> If this sounds like a good idea I can work on an implementation.

[toAPK][0] is already an existing tool that does already generate
APKBUILDs from PKGBUILDs.

Note that, even though the files look similar, there is still a
difference in packaging policies that you need to take into account as
well, which such tools cannot cover.

[0]:https://gitlab.com/Durrendal/toAPK