Subject: [alpine-devel] [Proposal] Remove "# Contributors:" from APKBUILDs

From: "Tmp File" <[email-masked]>
Date: Tue, 11 Jul 2017 15:40:12 +0200

Hello Alpinists.

I think the contributors on an APKBUILD doesn't give much useful information and only makes the APKBUILDs longer.
In the off chance you want to see who contributed in the past to a package, you can use git log.
Most times only the maintainer is useful.
If he doesn't answer, you can look at whoever else contributed to the package with git log.
It'll be much more detailed and give a better idea.
As a good side-effect this would also make the maintainer of a package easier to parse.

How do you feel about it?
If you like it I can send PRs to deal with this.

Thank you.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: William Pitcock <[email-masked]>
Date: Wed, 12 Jul 2017 01:59:49 -0500

Hello,

> As a good side-effect this would also make the maintainer of a package easier to parse.

I agree, however I also think allowing multiple Maintainer lines is important.
We may also want to keep Contributor lines for restricted packages
where only some people are allowed to touch them, but right now our
commit scripts don't do that specific kind of processing.

William

---

---

From: "Tmp File" <[email-masked]>
Date: Wed, 12 Jul 2017 14:19:42 +0200

> I agree
Good.
I'll try and send a PR later today or tomorrow removing "# Contributor:" and leaving only "# Maintainer:"

> however I also think allowing multiple Maintainer lines is important.
I have no opinion about multiple Maintainer lines.
You should discuss that with other people.
But I did found some different opinion on the bugtracker: https://bugs.alpinelinux.org/issues/5421

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 12 Jul 2017 16:25:18 +0200

On Wed, 12 Jul 2017 01:59:49 -0500

> I agree, however I also think allowing multiple Maintainer lines is important.

The idea with having a single maintainer is that one single person has
the responsability for the package. This is to avoid situation where
all the maintainers expect the other maintainers to act.

When you are alone maintainer there is no doubt who should follow up
and make sure things gets fixed.

I am open to add a field for multiple comaintainers though.

We should probably also change it from being a comment in apkbuild to a shell variable.

eg: 

maintainer="...."

---

---

From: "V.Krishn" <[email-masked]>
Date: Sun, 16 Jul 2017 05:01:12 +0530

> > > I think the contributors on an APKBUILD doesn't give much useful
> > > information and only makes the APKBUILDs longer. In the off chance you
> > > want to see who contributed in the past to a package, you can use git
> > > log. Most times only the maintainer is useful.
> > > If he doesn't answer, you can look at whoever else contributed to the
> > > package with git log. It'll be much more detailed and give a better
> > > idea.

This is were adding auto-flagging in https://pkgs.alpinelinux.org/flagged 
interface could be a help.
The scripts checks the ordered (occurrence) of maintainers in apkbuild file.

Moment a new version of pkg is auto flagged, it emails to first maintainer.
(or the next depending on stats)

Once maintainer acts upon the email he/she can send back mqtt msg with some 
pre-defined msg (the mqtt pub format can be normalized). 

The msg triggers a increment count for that maintainer for WIP or pkgs.
The number of pkgs a maintainer can tag as WIP can be set as quota,
or there can be round-robin on multi-maintainer'ed pkgs.

Interface https://pkgs.alpinelinux.org/flagged can be enhanced,
1. Message columns would show the current state
2. Have a Msg history link
3. Stats page for maintainers showing work in hand

Having he whole cli based with web-based gui wrapper may be more desirable.

> We should probably also change it from being a comment in apkbuild to a

May not be needed.

-- 
Regards.
V.Krishn

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 12 Jul 2017 16:30:54 +0200

On Tue, 11 Jul 2017 15:40:12 +0200

> How do you feel about it?

The contributors does not provide any vital information but I think it
is a nice way to give credit to people who contribute. Even if you do a
minor change, and even if you don't create the commit/patch, you can
still have your name there and be proud of have contributed.

> If you like it I can send PRs to deal with this.

I suppose you should ask the contributors in question how they feel
about it. If they are ok with it, then I am too.

-nc

---