Subject: [alpine-devel] Packages with invalid source="...." url

From: "Tmp File" <[email-masked]>
Date: Sat, 15 Jul 2017 22:22:14 +0200

Hey Alpinists.

I found 28 packages that don't build locally because the source="...." url doesn't return a valid upstream tarball.
It could be that it changed over time or the mirror is dead.
Worth checking each one individually.
HTH

main/ca-certificates
main/dev86
main/fcgi
main/libmikmod
main/live-media
main/lsof
main/mutagen
main/perl-date-manip
main/perl-test2-suite
main/putty
main/py-twisted
main/run-parts
main/unzip
main/xen
main/zip
community/bsm-simple-themes
community/gsoap
community/wireshark
testing/amule
testing/boost-coroutine
testing/corkscrew
testing/dnssec-tools
testing/hdf5
testing/libcoro
testing/ostinato
testing/subtitleeditor
non-free/3dm2
non-free/netperf

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: "A. Wilcox" <[email-masked]>
Date: Wed, 19 Jul 2017 02:40:29 -0500

On 15/07/17 15:22, Tmp File wrote:
> Hey Alpinists.
> 
> I found 28 packages that don't build locally because the
> source="...." url doesn't return a valid upstream tarball. It could
> be that it changed over time or the mirror is dead. Worth checking
> each one individually. HTH
> 
> main/ca-certificates

For ca-certificates, we have done some stuff in Adélie to fix that:

https://code.foxkit.us/adelie/aports/commit/be65030c173745e6875e5fd72adfccd3e24aba52

Feel free to adapt this to Alpine.  You probably want to put libressl
instead of OpenSSL in there.  (We use OpenSSL because libressl does
not work well or at all on some of the chips to which we are porting.)

Best,
--arw

-- 
A. Wilcox (awilfox)
Project Lead, Adélie Linux
http://adelielinux.org