Subject: [alpine-devel] [PATCH 1/2] testing/getmail: depends on python

From: Dubiousjim <[email-masked]>
Date: Thu, 27 Jun 2013 02:12:24 -0400

---
 testing/getmail/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/testing/getmail/APKBUILD b/testing/getmail/APKBUILD
index 3facef3..b5dc763 100644
--- a/testing/getmail/APKBUILD
+++ b/testing/getmail/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="POP3, IMAP4, and SDPS mail retriever with Maildir delivery"
 url="http://pyropus.ca/software/getmail/"
 arch="noarch"
 license="GPL2"
-depends=""
+depends="python"
 depends_dev=""
 makedepends="python-dev"
 install=""
-- 
1.8.3.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Dubiousjim <[email-masked]>
Date: Thu, 27 Jun 2013 02:12:25 -0400

To be honest, I think these are irrelevant to the functioning of the program,
since the files in question are imported by the offlineimap app, rather than
being run as scripts. (Not sure why the shebang lines are there at
all...cruft?)
---
 testing/getmail/APKBUILD | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/testing/getmail/APKBUILD b/testing/getmail/APKBUILD
index b5dc763..013c863 100644
--- a/testing/getmail/APKBUILD
+++ b/testing/getmail/APKBUILD
@@ -33,6 +33,8 @@ build() {
 package() {
 	cd "$_builddir"
 	python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+	# fix some broken shebang calls
+	sed -i -e "s|#![ ]*/usr/bin/env python2\.3|#!/usr/bin/env python|" $(find $pkgdir -name '*.py')
 }
 
 md5sums="1ca7e1bc034cf5578e8ceb251668962a  getmail-4.39.0.tar.gz"
-- 
1.8.3.1

---