Subject: [alpine-devel] [PATCH 1/2] alpine-xen: add xen-xend package

From: Roger Pau Monne <[email-masked]>
Date: Thu, 13 Sep 2012 15:31:00 +0100

Since xend is deprecated in 4.2, we will split it in a different
subpackage, that will not be installed by default.
---
 alpine-xen.packages | 1 +
 1 file changed, 1 insertion(+)

diff --git a/alpine-xen.packages b/alpine-xen.packages
index 9ec5347..834cb25 100644
--- a/alpine-xen.packages
+++ b/alpine-xen.packages
@@ -5,4 +5,5 @@ network-extras
 openssl
 tzdata
 xen
+xen-xend
 multipath-tools
-- 
1.7.11.4

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Roger Pau Monne <[email-masked]>
Date: Thu, 13 Sep 2012 15:31:01 +0100

Allow user to set params to pass to the Xen Hypervisor kernel. An
example about serial console boot is provided.
---
 Makefile           | 4 ++--
 alpine-xen.conf.mk | 3 +++
 2 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/Makefile b/Makefile
index 3676278..4bc0e5f 100755
--- a/Makefile
+++ b/Makefile
@@ -271,7 +271,7 @@ ifeq ($(PROFILE), alpine-xen)
 	@for flavor in $(KERNEL_FLAVOR); do \
 		echo "label xen-$$flavor"; \
 		echo "	kernel /boot/mboot.c32"; \
-		echo "	append /boot/xen.gz --- /boot/$$flavor alpine_dev=cdrom:iso9660 modules=loop,squashfs,sd-mod,usb-storage,floppy,sr-mod modloop=/boot/$$flavor.modloop.squashfs $(BOOT_CONSOLE) --- /boot/$$flavor.gz"; \
+		echo "	append /boot/xen.gz $(XEN_PARAMS) --- /boot/$$flavor alpine_dev=cdrom:iso9660 modules=loop,squashfs,sd-mod,usb-storage,floppy,sr-mod modloop=/boot/$$flavor.modloop.squashfs $(BOOT_CONSOLE) --- /boot/$$flavor.gz"; \
 	done >>$@
 else
 	@echo "default $(KERNEL_FLAVOR_DEFAULT)" >>$@
@@ -292,7 +292,7 @@ ifeq ($(PROFILE), alpine-xen)
 	@for flavor in $(KERNEL_FLAVOR); do \
 		echo "label xen-$$flavor"; \
 		echo "	kernel /boot/mboot.c32"; \
-		echo "	append /boot/xen.gz --- /boot/$$flavor alpine_dev=usbdisk:vfat modules=loop,squashfs,sd-mod,usb-storage modloop=/boot/$$flavor.modloop.squashfs $(BOOT_CONSOLE) --- /boot/$$flavor.gz"; \
+		echo "	append /boot/xen.gz $(XEN_PARAMS) --- /boot/$$flavor alpine_dev=usbdisk:vfat modules=loop,squashfs,sd-mod,usb-storage modloop=/boot/$$flavor.modloop.squashfs $(BOOT_CONSOLE) --- /boot/$$flavor.gz"; \
 	done >>$@
 else
 	@echo "default $(KERNEL_FLAVOR_DEFAULT)" >>$@
diff --git a/alpine-xen.conf.mk b/alpine-xen.conf.mk
index 22642d5..13ad7ec 100644
--- a/alpine-xen.conf.mk
+++ b/alpine-xen.conf.mk
@@ -1,3 +1,6 @@
 ALPINE_NAME     := alpine-xen
 MODLOOP_EXTRA   :=
 KERNEL_FLAVOR   := grsec
+# Example of serial console boot and Dom0 memory limit
+#XEN_PARAMS	:= com1=115200,8n1 console=com1 dom0_mem=512M
+#BOOT_CONSOLE	:= console=hvc0
-- 
1.7.11.4

---