Subject: Trademarks and redistribution

From: "Daniels, Hans-Joachim" <[email-masked]>
Date: Mon, 29 Jul 2019 09:09:34 +0000

Hello,
how does Alpine Linux officially treat the distribution of modified binaries (e.g. Docker Images) with respect to trademarks?

Ubuntu for example explicitly says on https://ubuntu.com/legal/intellectual-property-policy

> Any redistribution of modified versions of Ubuntu must be approved, ...
> Otherwise you must remove and replace the Trademarks and will need to recompile the source code to create your own binaries.

There are lots of Alpine Linux based Docker images out there, so I'd assume Alpine is OK with that, but I can't find any official statement regarding the use of the Alpine Linux trademarks for binary redistributions.

Thanks for clarification,
Hans-Joachim

________________________________

Turck Electronics GmbH | Geschäftsführer, Managing Director: Hermann Schwagmann, Guido Frohnhaus | Sitz, Registered Office: Detmold | Registergericht, Register Court: Amtsgericht Lemgo HRB 4921

Wichtiger Hinweis: Diese E-Mail enthält Betriebs- oder Geschäftsgeheimnisse, rechtlich geschützte oder sonstige vertrauliche Informationen und ist ausschließlich für den Empfänger bestimmt. Sollten Sie diese E-Mail irrtümlich erhalten haben, ist Ihnen eine Kenntnisnahme des Inhalts, eine Vervielfältigung, Weitergabe oder sonstige Nutzung des Inhalts der E-Mail ausdrücklich untersagt. Bitte benachrichtigen Sie sofort den Absender und vernichten Sie die empfangene E-Mail.

Important Note: This e-mail may contain trade or business secrets, privileged, undisclosed or otherwise confidential information and is only intended for its addresses. If you have received this e-mail in error, you are hereby notified that any review, copying, distribution or any use of the content hereof is strictly prohibited. Please inform the sender immediately and destroy the received e-mail.

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Mon, 29 Jul 2019 10:22:35 -0400

i can see a part that makes sense but seems may have some ambiguity:

*"You can redistribute Ubuntu, but only where there has been no
modification to it."*

for alpine could be* "you can redistribute it and marks as modified ... to
reflect it"*

And that can be aplly to alpine too:

*"Ubuntu is an aggregate work; this policy does not modify or reduce rights
granted under licences which apply to specific works in Ubuntu."*

also about:

> Otherwise you must remove and replace the Trademarks and will need to
recompile the source code to create your own binaries.

apine its a trademark ?

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

El lun., 29 de jul. de 2019 a la(s) 05:09, Daniels, Hans-Joachim (
[email-masked]) escribió:

> Hello,
> how does Alpine Linux officially treat the distribution of modified
> binaries (e.g. Docker Images) with respect to trademarks?
>
> Ubuntu for example explicitly says on
> https://ubuntu.com/legal/intellectual-property-policy
>
> > Otherwise you must remove and replace the Trademarks and will need to
> recompile the source code to create your own binaries.
>
> There are lots of Alpine Linux based Docker images out there, so I'd
> assume Alpine is OK with that, but I can't find any official statement
> regarding the use of the Alpine Linux trademarks for binary redistributions.
>
> Turck Electronics GmbH | Geschäftsführer, Managing Director: Hermann
> Schwagmann, Guido Frohnhaus | Sitz, Registered Office: Detmold |
> Registergericht, Register Court: Amtsgericht Lemgo HRB 4921
>
> Wichtiger Hinweis: Diese E-Mail enthält Betriebs- oder
> Geschäftsgeheimnisse, rechtlich geschützte oder sonstige vertrauliche
> Informationen und ist ausschließlich für den Empfänger bestimmt. Sollten
> Sie diese E-Mail irrtümlich erhalten haben, ist Ihnen eine Kenntnisnahme
> des Inhalts, eine Vervielfältigung, Weitergabe oder sonstige Nutzung des
> Inhalts der E-Mail ausdrücklich untersagt. Bitte benachrichtigen Sie sofort
> den Absender und vernichten Sie die empfangene E-Mail.
>
> Important Note: This e-mail may contain trade or business secrets,
> privileged, undisclosed or otherwise confidential information and is only
> intended for its addresses. If you have received this e-mail in error, you
> are hereby notified that any review, copying, distribution or any use of
> the content hereof is strictly prohibited. Please inform the sender
> immediately and destroy the received e-mail.
>

---

From: "Daniels, Hans-Joachim" <[email-masked]>
Date: Mon, 5 Aug 2019 14:30:30 +0000

Hello,

>>>"You can redistribute Ubuntu, but only where there has been no modification to it."
> for alpine could be "you can redistribute it and marks as modified ... to reflect it"

What qualifies as "marked as modified"?
Being a Docker images which uses Alpine as a base layer and packs any "modification" into another Docker image layer?

>> Otherwise you must remove and replace the Trademarks and will need to recompile the source code to create your own binaries.

Your last question left me puzzled. Somehow I can't imagine that the project name isn't protected.
But if Alpine thinks different than Ubuntu and doesn't want any Iceweasels running around and is fine with custom images containing the name Alpine Linux (which wouldn't have much user visibility anyway since we're thinking of server Docker images), then this would be an answer for my question.

Where could I find a confirmation on that?

Thanks,
Hans-Joachim

---

From: Daniel Isaksen <[email-masked]>
Date: Mon, 05 Aug 2019 14:40:47 +0000

Hello Hans-Joachim,

Alpine Linux has no corporate backer, and does not have any legal entity
(i.e. NPO) governing it - it is unlike Ubuntu largely a community effort.

If you were to distribute a modified Alpine Linux image, you would most likely
be including your software rather than altering the actual software, logo, or
copyright notices created by Alpine developers in a malicious way.

As for the logo guidelines: https://lists.alpinelinux.org/~alpine/devel/%3CCA%2BT2pCHpuJcz%3DZs9LkSw%3DJqdrao2kdBfbyTrQsdESKH%3D47tSHw%40mail.gmail.com%3E

Short answer: You are entirely fine using Alpine as the base image for your
Docker containers.

-----
Sincerely / Med vennlig hilsen,
Daniel Isaksen <[email-masked]> (https://duniel.no)

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

---

From: Natanael Copa <[email-masked]>
Date: Tue, 6 Aug 2019 07:08:59 +0200

Hi,

On Mon, 5 Aug 2019 14:30:30 +0000

> Your last question left me puzzled. Somehow I can't imagine that the project name isn't protected.

I spoke with a lawyer in USA a couple of years ago about this. First,
"Linux" is already trademarked, so we can not trademark "Alpine Linux".
I haven't checked with "Alpine" but it would surprise me if it wasn't
already.

Second, you cannot selectively enforce a trademark, so it requires a
lot of effort to enforce it and is very expensive. If you don't enforce
it everywhere and always, it loses its legal power.

Third, as Daniel mentioned, we still don't have any legal entity.

> But if Alpine thinks different than Ubuntu and doesn't want any
> Iceweasels running around and is fine with custom images containing
> the name Alpine Linux (which wouldn't have much user visibility
> anyway since we're thinking of server Docker images), then this would
> be an answer for my question.
> 

We are happy as long as you use the Alpine name according the
principles for the logo guidelines, as Daniel mentioned.

https://lists.alpinelinux.org/~alpine/devel/%3CCA%2BT2pCHpuJcz%3DZs9LkSw%3DJqdrao2kdBfbyTrQsdESKH%3D47tSHw%40mail.gmail.com%3E

Thanks!

---

From: "Daniels, Hans-Joachim" <[email-masked]>
Date: Tue, 6 Aug 2019 06:09:46 +0000

Good morning,

> We are happy as long as you use the Alpine name according the principles for the logo guidelines, as Daniel mentioned.

Thanks a lot for your clarification!

To my eyes, this information would be worth a more prominent place on your website than being buried in the mailing list archive.

Thanks again,
Hans-Joachim