Subject: apk upgrade problem

From: Hilix <[email-masked]>
Date: Thu, 10 Dec 2020 01:30:46 +0100

...how can I solve this "apk upgrade" problem:

---------------------------------------------------------------------
# apk update
Upgrading critical system libraries and apk-tools:
(1/1) Upgrading apk-tools (2.12.0-r1 -> 2.12.0-r2)
Executing busybox-1.32.0-r4.trigger
Continuing the upgrade transaction with new apk-tools:
ERROR: unable to select packages:
   nettle-3.5.1-r1:
     conflicts: nettle-3.6-r0
     satisfies: gnutls-3.6.15-r0[so:libhogweed.so.5] gnutls-3.6.15-r0[so:libnettle.so.7]
xorg-server-1.20.10-r0[so:libnettle.so.7]
   nettle-3.6-r0:
     conflicts: nettle-3.5.1-r1
     satisfies: claws-mail-3.17.8-r0[so:libnettle.so.8]
---------------------------------------------------------------------

I cannot "apk del" neither nettle-3.5.1-r1 nor nettle-3.6-r0
because of (Cross?-) Dependencies.

Is there any appropriate force option in apt to get rid of one of them?
I've tried: "--force-brocken -world", then all upgrades are done, but after reboot the GUI (XFCE) doesn't come up again.

Any helpful hints would be appreciated. Thanks and regards. / Hilmar.

------------------
# uname -a
Linux alpxf 5.4.78-0-virt #1-Alpine SMP Thu, 19 Nov 2020 12:04:00 UTC x86_64 Linux

# cat /etc/os-release
NAME="Alpine Linux"
ID=alpine
VERSION_ID=3.13.0_alpha20200917
PRETTY_NAME="Alpine Linux edge"
HOME_URL="https://alpinelinux.org/"
BUG_REPORT_URL="https://bugs.alpinelinux.org/"
--------------------
My /etc/apk/repositories:
#/media/cdrom/apks
http://alpine.mirror.wearetriple.com/v3.12/main
http://alpine.mirror.wearetriple.com/v3.12/community
http://alpine.mirror.wearetriple.com/edge/main
http://alpine.mirror.wearetriple.com/edge/community
http://alpine.mirror.wearetriple.com/edge/testing
-----------------------

---

From: Ariadne Conill <[email-masked]>
Date: Thu, 10 Dec 2020 03:03:11 GMT

Hello,

> ...how can I solve this "apk upgrade" problem:

This is because you are trying to mix packages from edge with packages from 
3.12.  As edge undergoes SONAME transitions, it become more difficult to mix 
packages.

The solution is to choose your preference of either the v3.12 branch or edge, 
and then do apk upgrade --available after disabling the other repositories.  
You cannot mix branches and expect it to work long term.

Ariadne

---

From: Hilix <[email-masked]>
Date: Thu, 10 Dec 2020 16:19:41 +0100

Hi Ariadne,

thanks for your quick response!

Your hint concerning basic and edge repos did it! :-)

I've commented out the stable repos (3.12) in the repositories file.
The (big) update (apk upgrade -a) then passed through without errors, but lightdm-login has frozen up again after reboot
Then restoring the alpine image (VM) from backup, and repeating these steps so far.

But before reboot, this time I immediately logged off and in to check GUI-login and no freeze at this time.
Then reboot. Login (xfce/lightdm)  was ok now. :-)
Don't know, if this had an effect anyhow

Is it possible to leave the 3.12/stable repos deactivated, and only update/upgrade from the edge repos?

Thanks a lot again and regards. / Hilmar.

---

From: Ariadne Conill <[email-masked]>
Date: Fri, 11 Dec 2020 07:24:17 GMT

Hello,

On Thursday, December 10, 2020 8:19:41 AM MST Hilix wrote:
> The (big) update (apk upgrade -a) then passed through without errors, but
> lightdm-login has frozen up again after reboot Then restoring the alpine
> image (VM) from backup, and repeating these steps so far.
> 
> But before reboot, this time I immediately logged off and in to check
> GUI-login and no freeze at this time. Then reboot. Login (xfce/lightdm) 
> was ok now. :-)

Yes, but sometimes during an upgrade, services need to be restarted, which is 
probably why lightdm froze up on you (it probably needed to be restarted).

Ariadne