Subject: [alpine-user] advice on using alpine

From: Max Waterman <[email-masked]>
Date: Sat, 02 Jun 2018 15:22:15 +0100

Hi,

I want to set up a router to use with expressvpn in China. I have previously just used the s/w client on the various platforms I have, but there is a limit to the number of them I can use at the same time, and I frequently have to manage that use. They allow you to set up a router to connect to the VPN so that I can use as many as I like at the same time.

I had looked at some routers (expressvpn even sell them), but I read they are quite underpowered for VPN use, so I am looking to repurpose an old laptop to do the job for me. It's not the greatest laptop, and doesn't even have 5GHz wifi, but I figured it was worth a try before forking out for something better.

The laptop is an old 'netbook' - a Lenovo S10-3t:

Processor	1.8 GHz Intel Atom N470
Memory	2GB, 667 MHz DDR2
Chipset	NM10

It has an ethernet port, and wifi, plus USB to which I could attach ethernet adaptors for the few devices I have with only physical interfaces (eg an old Mac Mini).

I was considering just putting Ubuntu on it, but it seems like there is a lot of waste in that solution, plus I'd have to set it up myself; so I looked for a more purpose build distribution, when I came across Alpine.

So, I am wondering if there is a specific set of instructions for my scenario.

I want to have a wired connection to our main router, and my various devices connect via wifi, or USB ethernet.

Any advice?

Thanks,

Max.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Vincent Bentley <[email-masked]>
Date: Sat, 2 Jun 2018 17:51:36 +0100

I have never been to China. I have never used ExpressVPN. But I know how 
to search for information online.

It appears that the Chinese government has banned the use of unlicensed 
commercial VPNs in China. I assume this ban also includes ExpressVPN 
unless they have a license.
https://www.quora.com/Is-using-VPN-illegal-in-China-in-2018
https://www.quora.com/How-can-I-use-a-VPN-in-China

ExpressVPN Linux Client uses OpenVPN
https://www.expressvpn.com/support/vpn-setup/app-for-linux/

If you are not comfortable setting up a Linux system then maybe a router 
purchase is the way to go.

An Ubuntu based system for ExpressVPN would probably be easier at 
tackling for a first timer than setting up OpenVPN client on Alpine Linux.

However, there is a how-to that although not written specifically for 
your laptop, it explains the steps required.
https://wiki.alpinelinux.org/wiki/Experiences_with_OpenVPN-client_on_ALIX.2D3 

---

---

From: Max Waterman <[email-masked]>
Date: Sun, 03 Jun 2018 15:35:28 +0100

Hi,

Yeah, I also know how to search for information online :p

I'm not worried about using VPN in China, nor do I have trouble using ExpressVPN in China; I've been doing both for a long time.

I am comfortable setting up a linux system - I've been using Unix/Linux since the mid-'80s. OpenVPN, on the other hand, I know from experience is a bit of a fiddle - I could probably do it, but I kind of value the facility of Tomato, which I had been using on my Linksys WRT 54G for several years. I did play with flashing a VPN version of DD-WRT, but I ran into a bit of trouble since the version that supports the 54G is so old, and I was told that even if I did get it working that I likely wouldn't be happy with the performance.

I also had a quick try at getting a Pi working, but I don't own that, and really should be one of the devices plugged into the VPN; so I would have had to buy another one for a more permanent solution, which is why I was looking around for something more suitable - this was the device I was considering:

https://www.amazon.co.uk/dp/B01GBHCHDI/?coliid=IPDMNNRFREYGB&colid=1JBIG8GK2O3D8&psc=0&ref_=lv_ov_lig_dp_it

IINM, it has a CPU that accelerates encryption/decryption (AES-NI?).

Anyway, the price of that was slightly higher than I was willing to spend and I figured I'd see if I could get this laptop working (I don't think it has the acceleration, but it's worth a try before spending money).

I was 'IT guy' many years ago for a small US company in China and set up a VPN for them - well, actually (like this time) while I could probably get something working with some fiddling, I figured it was better to 'get it right, and so contracted James Yonan to set it up for me. That worked nicely. That was quite some time ago, and I moved back into s/w engineering, and I've not done much in the way of sysadmin stuff since - just the usual stuff I need for development.

Anyway, the convenience of Tomato and DD-WRT lead me to look for something similar for a laptop, and ending up on the Alpine web site. I downloaded it and started setting it up; but got distracted and figured I'd finish it off later. While thinking about it, I wondered if there was a set of instructions *specifically* for what I'm trying to do, hence me asking.

So, while I'm not strictly speaking a first timer, it is that sort of 'ease of use' that I am looking for, both for initial setup and for ongoing maintenance.

Having a quick look at the Wiki page you reference, I think it is very much the same sort of thing I'm look for, so thanks for that. Since you mention I might as well just use Ubuntu, I'll also take that advice and do that if I struggle or get frustrated setting up Alpine.

Thanks for the advice.

Regards,

Max.

---