Subject: Unmounting disk after boot.

From: Tomas <[email-masked]>
Date: Sat, 25 Jul 2020 19:24:26 -0300

Hello,
 one of alpine's key selling point is that it is so small that it can 
load itself into RAM. However I cannot unmount my usb once I booted, I 
must physically remove it and reattach it if I wish to inspect its 
contents, run fsck, format it or other actions.

If I run 'ps ax' 
it seems that most processes are within brackets (I think this means 
they don't correspond to any file on disk) except for one related to 
'login' and a few other ones about 'tty'

Is this a known bug? Is there a way to safely unmount the drive used to boot?

Thank you for your attention, and glory to the smol OS.

---

From: "Dr. Sascha Effert" <[email-masked]>
Date: Sun, 26 Jul 2020 07:09:28 +0000 (UTC)

Hi,

never tried, but according https://en.m.wikipedia.org/wiki/List_of_Linux_distributions_that_run_from_RAM
your use case shoub be supported by adding "toram" as Kernel parameter. Have you done so?

Bests

Sascha

26.07.2020 00:25:00 Tomas <[email-masked]>:

> Hello, one of alpine's key selling point is that it is so small that it can load itself into RAM. However I cannot unmount my usb once I booted, I must physically remove it and reattach it if I wish to inspect its contents, run fsck, format it or other actions.
> 
> If I run 'ps ax' it seems that most processes are within brackets (I think this means they don't correspond to any file on disk) except for one related to 'login' and a few other ones about 'tty'
>