Subject: Problem with starting Wayland compositor

From: mitochondriummulticast <[email-masked]>
Date: Sat, 8 Aug 2026 11:01:35 +0200

Alpine Edge x86_64, not on VM or WLS.
I have only one GPU.

Outputs of commands;

1. seatd-launch -l error dwl :
libEGL warning: egl: failed to create dri2 screen
00:00:00.479 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
libEGL warning: egl: failed to create dri2 screen
00:00:00.482 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
00:00:00.482 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to load driver"
00:00:00.482 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "eglInitialize"
00:00:00.482 [ERROR] [render/egl.c:269] Failed to initialize EGL
00:00:00.482 [ERROR] [render/egl.c:611] Failed to initialize EGL context
00:00:00.482 [ERROR] [render/gles2/renderer.c:499] Could not initialize EGL
00:00:00.482 [ERROR] [backend/drm/renderer.c:23] Renderer did not 
support importing DMA-BUFs
libEGL warning: egl: failed to create dri2 screen
00:00:00.487 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
libEGL warning: egl: failed to create dri2 screen
00:00:00.489 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
00:00:00.489 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to load driver"
00:00:00.489 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "eglInitialize"
00:00:00.489 [ERROR] [render/egl.c:269] Failed to initialize EGL
00:00:00.489 [ERROR] [render/egl.c:611] Failed to initialize EGL context
00:00:00.489 [ERROR] [render/gles2/renderer.c:499] Could not initialize EGL
00:00:00.489 [ERROR] [render/wlr_renderer.c:279] Could not initialize 
renderer
couldn't create renderer

2.lspci | grep -iE 'UHD' :
00:02.0 VGA compatible controller: Intel Corporation TigerLake-H GT1 
[UHD Graphics] (rev 01)

3.apk list --installed | grep -iE 'intel|vulkan|mesa' :
mesa-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND BSL-1.0) [installed]
mesa-dri-gallium-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND BSL-1.0) 
[installed]
mesa-egl-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND BSL-1.0) [installed]
mesa-gbm-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND BSL-1.0) [installed]
mesa-gles-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND BSL-1.0) 
[installed]
mesa-va-gallium-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND BSL-1.0) 
[installed]
mesa-vulkan-intel-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND 
BSL-1.0) [installed]
vulkan-loader-1.4.347-r0 x86_64 {vulkan-loader} (Apache-2.0) [installed]

---

From: LN Liberda <[email-masked]>
Date: Sat, 8 Aug 2026 19:09:33 +0200

Check dmesg for errors.

Op 08-08-2026 om 11:01 schreef mitochondriummulticast:
> mesa-dri-gallium-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND 
> BSL-1.0) [installed]
> mesa-va-gallium-26.1.6-r0 x86_64 {mesa} (MIT AND SGI-B-2.0 AND 
> BSL-1.0) [installed]
-- 
LN Liberda
it/she, het/zij, to [coś]/ona
https://liberda.nl/

---

From: Naomi Rennie-Waldock <[email-masked]>
Date: Sat, 08 Aug 2026 19:21:54 +0100

On 8 August 2026 10:01:35 BST, mitochondriummulticast <[email-masked]> wrote:
>00:02.0 VGA compatible controller: Intel Corporation TigerLake-H GT1 [UHD Graphics] (rev 01)

Can you `lspci -nn | grep VGA` instead for the hardware ID?

And `lsmod | grep -e xe -e i915` ?

I *think* your GPU is 8086:9a60, which is supported by both i915 and xe, so you may need to blacklist one driver and try the other one.

---

From: [email-masked]
Date: Tue, 11 Aug 2026 18:40:27 +0200

Yes, it is 8086:9a60.

Starting compositor with  xe module blacklisted:

MESA: error: ZINK: failed to choose pdev
libEGL warning: egl: failed to create dri2 screen
00:00:01.919 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
MESA: error: ZINK: failed to choose pdev
libEGL warning: egl: failed to create dri2 screen
00:00:01.929 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
00:00:01.932 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to load driver"
00:00:01.933 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "eglInitialize"
00:00:01.933 [ERROR] [render/egl.c:269] Failed to initialize EGL
00:00:01.933 [ERROR] [render/egl.c:611] Failed to initialize EGL context
00:00:01.933 [ERROR] [render/gles2/renderer.c:499] Could not initialize EGL
00:00:01.938 [ERROR] [render/vulkan/renderer.c:2540] Could not match drm 
and vulkan device
00:00:01.938 [ERROR] [backend/drm/renderer.c:23] Renderer did not 
support importing DMA-BUFs
00:00:01.960 [ERROR] [backend/libinput/backend.c:111] libinput 
initialization failed, no input devices
00:00:01.960 [ERROR] [backend/libinput/backend.c:112] Set 
WLR_LIBINPUT_NO_DEVICES=1 to suppress this check
00:00:01.960 [ERROR] [backend/multi/backend.c:32] Failed to initialize 
backend.
startup: backend_start

Starting compositor with  i915 module blacklisted:

MESA: error: ZINK: vkEnumeratePhysicalDevices failed 
(VK_ERROR_INITIALIZATION_FAILED)
MESA: error: ZINK: failed to choose pdev
libEGL warning: egl: failed to create dri2 screen
00:00:01.959 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
MESA: error: ZINK: vkEnumeratePhysicalDevices failed 
(VK_ERROR_INITIALIZATION_FAILED)
MESA: error: ZINK: failed to choose pdev
libEGL warning: egl: failed to create dri2 screen
00:00:01.968 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
00:00:01.971 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to load driver"
00:00:01.972 [ERROR] [EGL] command: eglInitialize, error: 
EGL_NOT_INITIALIZED (0x3001), message: "eglInitialize"
00:00:01.972 [ERROR] [render/egl.c:269] Failed to initialize EGL
00:00:01.972 [ERROR] [render/egl.c:611] Failed to initialize EGL context
00:00:01.972 [ERROR] [render/gles2/renderer.c:499] Could not initialize EGL
00:00:01.977 [ERROR] [render/vulkan/vulkan.c:265] Could not retrieve 
physical devices: ERROR_INITIALIZATION_FAILED (-3)
00:00:01.977 [ERROR] [render/vulkan/renderer.c:2540] Could not match drm 
and vulkan device
00:00:01.977 [ERROR] [backend/drm/renderer.c:23] Renderer did not 
support importing DMA-BUFs
00:00:02.061 [ERROR] [backend/libinput/backend.c:111] libinput 
initialization failed, no input devices
00:00:02.061 [ERROR] [backend/libinput/backend.c:112] Set 
WLR_LIBINPUT_NO_DEVICES=1 to suppress this check
00:00:02.061 [ERROR] [backend/multi/backend.c:32] Failed to initialize 
backend.
startup: backend_start

---

From: LN Liberda <[email-masked]>
Date: Tue, 11 Aug 2026 18:55:23 +0200

Can you please check dmesg?

[email-masked] schreef op 11 augustus 2026 18:40:27 CEST:
>00:00:01.919 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
>00:00:01.929 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
>00:00:01.932 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to load driver"
>00:00:01.933 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "eglInitialize"
>00:00:01.938 [ERROR] [render/vulkan/renderer.c:2540] Could not match drm and vulkan device
>00:00:01.938 [ERROR] [backend/drm/renderer.c:23] Renderer did not support importing DMA-BUFs
>00:00:01.960 [ERROR] [backend/libinput/backend.c:111] libinput initialization failed, no input devices
>00:00:01.960 [ERROR] [backend/libinput/backend.c:112] Set WLR_LIBINPUT_NO_DEVICES=1 to suppress this check
>00:00:01.960 [ERROR] [backend/multi/backend.c:32] Failed to initialize backend.
>startup: backend_start
>
>MESA: error: ZINK: vkEnumeratePhysicalDevices failed (VK_ERROR_INITIALIZATION_FAILED)
>00:00:01.959 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
>MESA: error: ZINK: vkEnumeratePhysicalDevices failed (VK_ERROR_INITIALIZATION_FAILED)
>00:00:01.968 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to create screen"
>00:00:01.971 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "DRI2: failed to load driver"
>00:00:01.972 [ERROR] [EGL] command: eglInitialize, error: EGL_NOT_INITIALIZED (0x3001), message: "eglInitialize"
>00:00:01.977 [ERROR] [render/vulkan/vulkan.c:265] Could not retrieve physical devices: ERROR_INITIALIZATION_FAILED (-3)
>00:00:01.977 [ERROR] [render/vulkan/renderer.c:2540] Could not match drm and vulkan device
>00:00:01.977 [ERROR] [backend/drm/renderer.c:23] Renderer did not support importing DMA-BUFs
>00:00:02.061 [ERROR] [backend/libinput/backend.c:111] libinput initialization failed, no input devices
>00:00:02.061 [ERROR] [backend/libinput/backend.c:112] Set WLR_LIBINPUT_NO_DEVICES=1 to suppress this check
>00:00:02.061 [ERROR] [backend/multi/backend.c:32] Failed to initialize backend.
>startup: backend_start
>

---

From: [email-masked]
Date: Tue, 11 Aug 2026 20:49:29 +0200

dmesg | grep -i 'error'

[    0.152928] ACPI BIOS Error (bug): Could not resolve symbol 
[\_SB.PCI0], AE_NOT_FOUND (20250807/dswload2-162)
[    0.152932] ACPI Error: AE_NOT_FOUND, During name lookup/catalog 
(20250807/psobject-220)

I am not sure for what key words should I search for exactly.