Subject: [alpine-user] missing header sys/queue.h

From: Riccardo Mottola <[email-masked]>
Date: Thu, 28 Feb 2019 08:16:55 +0100

Hi,

while compiling ArctixFox I hit into this:

150:39.60 ../../dist/system_wrappers/sys/queue.h:4:15: fatal error: 
sys/queue.h: No such file or directory
150:39.61  #include_next <sys/queue.h>

any ideas? how did you get FireFox running? Is there a replacement I can 
conditionally enable (and then, next question, how to detect AlpineLinux 
sources compared to standard Linux)?

Riccard

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Adam Růžička <[email-masked]>
Date: Thu, 28 Feb 2019 07:39:59 +0000

Hi,
bsd-compat-headers package seems to provide that header.

-- Adam

On Thu, Feb 28, 2019 at 8:16 AM Riccardo Mottola <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Riccard

---
Unsubscribe:  [email-masked]<mailto:[email-masked]>
Help:         [email-masked]<mailto:[email-masked]>
---