Subject: [alpine-user] Custom partitioning - cannot get alpine to boot

From: Neoklis Kyriazis <[email-masked]>
Date: Fri, 11 May 2018 10:27:22 +0000 (UTC)

Hi

I am trying to install alpine with a manual custom partitioning of the SSD on my laptop.
I did eventually succeeded with the installation but it will not boot. Installation was done
using "setup-disk /mnt" where the root partition (sda3) was mounted on /mnt and the
boot and home partitions (sda1 and sda4) where mounted on /mnt/boot and /mnt/home.
setup-disk left me with a message that I might need to "fix" the MBR in order to boot.
Looking into /boot and / I beleive the installation looks complete.

I have used "power user" distros before (gentoo, arch and now void linux) but I am not
powerful enough, apparently, to resolve this on my own! ;-)

So please suggest some tips for me to try. Alpine seems original and interesting to me,
since I also have a couple of ARM micros (BeagleBone Black and CHIP) and would like to
try installing alpine on them. BBB is currently my home web server running Arch Linux.

My thanks in advance.

Neoklis

---

From: azarus <[email-masked]>
Date: Fri, 11 May 2018 14:04:42 +0200

> powerful enough, apparently, to resolve this on my own! ;-)
Hi.

Try giving some more information, like the exact partition tables, run
`fdisk -l /dev/sda` (with util-linux installed). Also, what filesystems
are you using? Bootloaders? Show us the bootloader configurations. What
Alpine are you using (3.7/edge/something else that shouldn't be used
currently?). There are many questions left open with your problem
report. Also, what constitutes "not booting"? How far does it get?
> try installing alpine on them. BBB is currently my home web server running Arch Linux.
Might try helping some more if you provide adequate information.
-- 
Sascha Paunovic <azarus>
email: [email-masked]
xmpp:  [email-masked]
PGP:   3A79D6CFD2567CF9

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Neoklis Kyriazis <[email-masked]>
Date: Fri, 11 May 2018 14:22:15 +0000 (UTC)

Hi
Thanks for trying to help, apologies for naive posting ;-)

I am trying the 3.7.0 release of Alpine of 2017-11-30. I have not enablededge repositories and I (eventually) succeeded with a default installation
following setup-alpine. The problem occured when I tried an installation
with a manual custom partition. All looks installed, but according to docs
I am reponsible for setting up the boot loader manually. This is what I
failed to do, don't know enough.

I used the grml rescue disk to collect the info below:

Here is the output from fdisk -l /dev/sda:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1   234441647   117220823+  ee  GPT

Here is the output of parted -l:

Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags
 1      2097kB  50.3MB  48.2MB  ext2            primary
 2      50.3MB  5000MB  4949MB  linux-swap(v1)  primary
 3      5000MB  15.0GB  10.0GB  ext4            primary
 4      15.0GB  25.0GB  10.0GB  ext4            primary
 5      25.0GB  50.0GB  25.0GB  ext4            primary
 6      50.0GB  100GB   50.0GB  ext4            primary

sda1 is the boot partition, sda3 the root partition and sda5 is home.
Other partitions may be used for dual-booting if needed.

Here is the listing of /dev/sda (the /boot partition).

boot@                ldlinux.c32   lost+found/            vesamenu.c32
config-hardened     ldlinux.sys   mboot.c32                vmlinuz-hardened
extlinux.conf        libcom32.c32  menu.c32
initramfs-hardened  libutil.c32   System.map-hardened

Here is the content of extlinux.conf:
# Generated by update-extlinux 6.04_pre1-r1
DEFAULT menu.c32
PROMPT 0
MENU TITLE Alpine/Linux Boot Menu
MENU HIDDEN
MENU AUTOBOOT Alpine will be booted automatically in # seconds.
TIMEOUT 30
LABEL hardened
  MENU DEFAULT
  MENU LABEL Linux hardened
  LINUX vmlinuz-hardened
  INITRD initramfs-hardened
  APPEND root=UUID=4c981da2-57cc-4e87-84a5-ea2e443d4370 modules=sd-mod,usb-storage,ext4 nomodeset quiet rootfstype=ext4

MENU SEPARATOR

The boot process stalls right at the beginning, e.g. the bios doesn't find
a boot loader on sda (the SSD) so it tries the other alternatives (cdrom 
and PXE boot) and then it stops, asking me to reboot and select another 
boot device.

--Best Regards
Neoklis - Ham Radio Call:5B4AZ
http://www.5b4az.org/