Subject: Static network configuration bug?

From: Mark Hills <[email-masked]>
Date: Thu, 19 Nov 2020 19:38:05 +0000 (GMT)

Following the wiki for a static IP setup:

  https://wiki.alpinelinux.org/wiki/Configure_Networking#IPv4_Static_Address_Configuration

It states the following for configuration:

  iface eth0 inet static
        address 192.168.1.150/24
        gateway 192.168.1.1

but this format of netmask does not cooperate:

  # service networking start
   * Starting networking ... *   lo ... [ ok ]
   *   eth0 ...ifup: don't have all variables for eth0/inet
   [ !! ]

I found I could specify full netmark; eg.

  iface eth0 inet static
        address 192.168.1.150
        netmask 255.255.255.0
        gateway 192.168.1.1

The same problem happens with IPv6 configuration, too. Is it the docs, or 
me that is wrong? This pattern repeats several times over in the doc.

-- 
Mark

---

From: Ariadne Conill <[email-masked]>
Date: Thu, 19 Nov 2020 12:40:16 -0700

> It states the following for configuration:

This syntax is only supported by ifupdown-ng, which is new to Alpine 3.13, or 
Debian ifupdown.  It's not supported by Busybox ifupdown.

The documentation has been updated to reflect ifupdown-ng.

Ariadne

---

From: Mark Hills <[email-masked]>
Date: Thu, 19 Nov 2020 19:46:19 +0000 (GMT)

> The documentation has been updated to reflect ifupdown-ng.

It could have been better to wait until after the release of 3.13 before 
updating the user docs, as they are broken now. I presume the old syntax 
is supported by ifupdown-ng.

Thanks for the immediate response.

-- 
Mark