Subject: [alpine-user] AlpineLinux on Banana Pi?

From: Steffen Nurpmeso <[email-masked]>
Date: Tue, 10 Apr 2018 20:57:23 +0200

Hello!

I want to buy an ARM system.  It will be my first, which is
a pity: the German magazine c't had a wonderful article on ARM
i think somewhere around 2000,2001,2002 or whatever, but anyway
before Donald Knuth was celebrating his 64th birthday!
I have always been fascinated ever since.  And became thrilled by
the RaspberryPi once it came up, because minimal energy usage, and
cheap.  Blabla.. :p  Never used anything but x86 before, except
for Commodore 64.

Anyway, two kits there are, one is Raspberry PI 3B+, the other is
a Banana Pi M2U.  Since i want to use this as a regular desktop
and development system i was thinking of the latter, since it has
2 GB of memory, the former only 1 GB.  I mean, Linux overcommits
memory and that works just fine, but the system is at limit with
a browser, anyway.

Thus my question: does anyone have experience with Banana Pi, does
it work with AlpineLinux?  Will patches to enable zstd also there
be accepted?  What about a browser.  Etc. etc. :-))
What do you say?  Anyone?

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jean-Louis Fuchs <[email-masked]>
Date: Wed, 18 Apr 2018 16:45:17 +0200

Hi Steffen

> it work with AlpineLinux?  Will patches to enable zstd also there

Well even the state of the linux-rpi is not too good. It has deviated from
the official raspi-kernel too much.

https://github.com/raspberrypi/linux

1. Not being up to date
2. Not being close enough to defconfig

make bcmrpi_defconfig (for raspi 1 and 0)
make bcm2709_defconfig (for raspi 2)
make bcmrpi3_defconfig (64bit for raspi 3, aarch64)

https://bugs.alpinelinux.org/issues/6370

I recently decided to try again to build a kernel for the raspi that is
more close. You can cross compile on alpine using
aports/scripts/bootstrap.sh $ARCH

You can also use https://github.com/multiarch/qemu-user-static to test
packages, which is not relevant to the kernel, but interesting if you
need to compile user-space programs.

If you build a kernel for yourself using abuild its quite fast, you
can be sloppy here and there. If you plan to submit the kernel to
alpine its going to be a lot of work (see aports/linux-vanilla) and
issue 6370.

> Will patches to enable zstd also there be accepted?  

If the Banana Pi hardware is so badly upstreamed like Raspberry Pi you
have to create linux-bpi. If it is close enough to Raspberry Pi and I
ever submit my Raspi-Kernel to Alpine, patches are probably ok.

> What about a browser.  Etc. etc. :-))
> What do you say?  Anyone?

I had no problems browsing with the raspi because of memory [1], the
problem was that linux-rpi does not support OpenGL and it was not
smooth. Again see issue 6370.

[1] 32-bit and musl-libc save a lot of memory.

Best,
    Jean-Louis

---

---

From: Jean-Louis Fuchs <[email-masked]>
Date: Mon, 9 Jul 2018 17:47:24 +0200

Hi Steffen

> make bcmrpi3_defconfig (64bit for raspi 3, aarch64)

The Raspberry PI images now use upstream config and support OpenGL.

https://wiki.alpinelinux.org/wiki/Raspberry_Pi#Enable_OpenGL_.28RPi_3.29

Kudos to Carlo Landmeter.
https://git.alpinelinux.org/cgit/aports/commit/main/linux-rpi?id=ff478c74b2ec90

Best,
    Jean-Louis

---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Tue, 10 Jul 2018 15:44:30 +0200

Jean-Louis Fuchs wrote in <[email-masked]>:
 |On Wed, Apr 18, 2018 at 04:45:17PM +0200, Jean-Louis Fuchs wrote:
 |
 |> make bcmrpi_defconfig (for raspi 1 and 0)
 |> make bcm2709_defconfig (for raspi 2)
 |> make bcmrpi3_defconfig (64bit for raspi 3, aarch64)
 |
 |The Raspberry PI images now use upstream config and support OpenGL.
 |
 |https://wiki.alpinelinux.org/wiki/Raspberry_Pi#Enable_OpenGL_.28RPi_3.29
 |
 |Kudos to Carlo Landmeter.
 |https://git.alpinelinux.org/cgit/aports/commit/main/linux-rpi?id=ff478c7\
 |4b2ec90

Thank you for the info and the work!  I am still looking forward
for it, but it will happen and then i am landing in a built nest.
^.^

Ciao,

--steffen
|

---