Subject: [alpine-user] st(1): a version with light background would be cool!

From: Steffen Nurpmeso <[email-masked]>
Date: Sat, 03 Nov 2018 20:54:49 +0100

Hello.

Would it be possible to have a st(1) port with a light background?
Or would that need to be a completely new port by itself?
I compile it here only with the patch below applied for this.
Just an idea, but would be cool to have a binary available.
Thanks!

P.S.: AlpineLinux works just perfect also on (pretty old though)
Acer Aspire and MacBook Air!  :--))

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)
diff --git a/config.def.h b/config.def.h
index 823e79f..74c1a7b 100644
--- a/config.def.h
+++ b/config.def.h
@@ -107,8 +107,9 @@ static const char *colorname[] = {
 	[255] = 0,
 
 	/* more colors can be added after 255 to use with DefaultXX */
-	"#cccccc",
-	"#555555",
+	"#f4ad42",
+	"#af2457",
+	"#fcfcf9"
 };

@@ -116,8 +117,8 @@ static const char *colorname[] = {
  * Default colors (colorname index)
  * foreground, background, cursor, reverse cursor
  */
-unsigned int defaultfg = 7;
-unsigned int defaultbg = 0;
+unsigned int defaultfg = 0;
+unsigned int defaultbg = 258;
 static unsigned int defaultcs = 256;
 static unsigned int defaultrcs = 257;

---

From: Cág <[email-masked]>
Date: Mon, 05 Nov 2018 18:03:51 +0000

> Just an idea, but would be cool to have a binary available.

I wonder how many people use pre-compiled versions st (or dwm for
that matter). Patches to use .Xresources exist though.

--
caóc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Wed, 07 Nov 2018 23:23:02 +0100

Hello Cág, all!

Cág wrote in <[email-masked]>:
 |> Would it be possible to have a st(1) port with a light background?
 |> Or would that need to be a completely new port by itself?
 |> I compile it here only with the patch below applied for this.
 |> Just an idea, but would be cool to have a binary available.
 |> Thanks!
 |
 |I wonder how many people use pre-compiled versions st (or dwm for
 |that matter). Patches to use .Xresources exist though.

Oh, thanks for pointing this out!  Cool!!  But.. not working for
st.background, st.foreground and st.cursorColor, please find
attached the original patch plus one which gets this stuff going!

Would be tremendous to have this like so in Alpine!

--steffen
|