Subject: Re: [alpine-user] ncurses source for Alpine package

From: Natanael Copa <[email-masked]>
Date: Thu, 10 Jan 2019 08:45:19 +0100

Hi!

On Wed, 9 Jan 2019 22:11:38 +0000
RICK KING <[email-masked]> wrote:

> I'm trying to backtrace from the Alpine package for the ncurses-libs
> package at version 6.1_p20180818-r0 that appears to be defined by
> this APKBUILD file
> (https://git.alpinelinux.org/aports/tree/main/ncurses/APKBUILD?id=b01bcbc9705e0ad4e6778c0a34ed376300577bbc<https://protect-us.mimecast.com/s/t_PKCyP2nvFrvJ7GfM4vdA?domain=git.alpinelinux.org>)
> 
>  When I follow the links out to the source location at
> invisible-mirror.net though, I find no source tarballs from this
> timeframe. It looks as if they've pruned a certain number of older
> releases (though this is just from this past August)
> 
>  Am I looking at something wrong on this? Or is this version of the
> package broken at this point due to the ncurses folks pruning the
> versions that are still out there?
> 
>  I'd appreciate any guidance you can help give me on this issue.

We store the sources on https://distfiles.alpinelinux.org.

The files from edge are removed after some time. They are found here:
https://distfiles.alpinelinux.org/distfiles

The sources for stable branches are stored "forever". You can find the
sources for v3.8 here:
https://distfiles.alpinelinux.org/distfiles/v3.8

I hope that helps!

-nc

>  Thanks,
> Rick King
> ADTRAN, Inc.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Thu, 10 Jan 2019 07:11:16 -0400

seems only opens on chromiun based browsers, on mozz other said : "Error
code: SSL_ERROR_PROTOCOL_VERSION_ALERT"  quite xtrange

El jue., 10 de ene. de 2019 a la(s) 03:45, Natanael Copa (
[email-masked]) escribió:

> > (
> https://git.alpinelinux.org/aports/tree/main/ncurses/APKBUILD?id=b01bcbc9705e0ad4e6778c0a34ed376300577bbc
> <
> https://protect-us.mimecast.com/s/t_PKCyP2nvFrvJ7GfM4vdA?domain=git.alpinelinux.org
> >)
> >

---

From: Natanael Copa <[email-masked]>
Date: Thu, 10 Jan 2019 12:48:02 +0100

On Thu, 10 Jan 2019 07:11:16 -0400
> code: SSL_ERROR_PROTOCOL_VERSION_ALERT"  quite xtrange

Works for me in firefox 62.0.3 x86_64. See attached screenshot.

-nc

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Thu, 10 Jan 2019 09:05:21 -0400

ok after some investigations seems its a bug in some version of precompiled
firefox binary..  (maybe a NSS compatibiliti problem)
now updated and using the lasted in repository

---

From: RICK KING <[email-masked]>
Date: Thu, 10 Jan 2019 16:07:21 +0000

That did the trick.  Thank you!
Rick

From: Natanael Copa <[email-masked]>
Sent: Thursday, January 10, 2019 1:45 AM
To: RICK KING <[email-masked]>
Cc: [email-masked]
Subject: Re: [alpine-user] ncurses source for Alpine package

Hi!

On Wed, 9 Jan 2019 22:11:38 +0000
RICK KING <[email-masked]<mailto:[email-masked]>> wrote:

> (https://git.alpinelinux.org/aports/tree/main/ncurses/APKBUILD?id=b01bcbc9705e0ad4e6778c0a34ed376300577bbc<https://protect-us.mimecast.com/s/-Dk7C31VGxsp1ogouQVUkg?domain=git.alpinelinux.org><https://protect-us.mimecast.com/s/t_PKCyP2nvFrvJ7GfM4vdA?domain=git.alpinelinux.org<https://protect-us.mimecast.com/s/-Dk7C31VGxsp1ogouQVUkg?domain=git.alpinelinux.org>>)
>

We store the sources on https://distfiles.alpinelinux.org<https://protect-us.mimecast.com/s/I8yoC4xGJyuBNE2ECMps-R?domain=distfiles.alpinelinux.org>.

The files from edge are removed after some time. They are found here:
https://distfiles.alpinelinux.org/distfiles<https://protect-us.mimecast.com/s/60wFC5yKgziZm3P3HN2QHV?domain=distfiles.alpinelinux.org>

The sources for stable branches are stored "forever". You can find the
sources for v3.8 here:
https://distfiles.alpinelinux.org/distfiles/v3.8<https://protect-us.mimecast.com/s/2doPC68KjAsr2767S2YcQA?domain=distfiles.alpinelinux.org>

I hope that helps!

-nc