Subject: APKBUILD python error no setup.py file

From: amc252 <[email-masked]>
Date: Wed, 13 May 2020 20:06:24 -0700

Hello,
I'm trying to build my first alpine pkg, trelby. I set up the dir with newapkbuild -y (since trelby is written in python).
However, when I run abuild, I get the following error: 
python3: can't open file 'setup.py': [Errno 2] No such file or directory
I have checked, and setup.py is there in the decompressed file /home/user/trelby/scr/trelby
what am I doing wrong?
-- 
amc252 <[email-masked]>

---

From: Leo <[email-masked]>
Date: Thu, 14 May 2020 03:38:34 -0300

On Wed, 13 May 2020 20:06:24 -0700
amc252 <[email-masked]> wrote:

> Hello,
> I'm trying to build my first alpine pkg, trelby. I set up the dir
> with newapkbuild -y (since trelby is written in python). However,
> when I run abuild, I get the following error: python3: can't open
> file 'setup.py': [Errno 2] No such file or directory I have checked,
> and setup.py is there in the decompressed file
> /home/user/trelby/scr/trelby what am I doing wrong?

Hello,

Please post the APKBUILD itself so we can get a full picture.

Regards
Leo