Subject: Trelby can't find wx module

From: amc252 <[email-masked]>
Date: Thu, 4 Jun 2020 17:36:39 -0700

Hello,
I'm trying to run Trelby on Alpine. I have installed Trelby dependencies: python, wxgtk (which should rpovide wxwidgets, py3-wxpython, and py3-lxml.
However, when I run Trelby from the terminal, I get the following error:
alpine:~$ trelby
Traceback (most recent call last):
  File "/usr/bin/trelby", line 8, in <module>
    import trelby
  File "/usr/share/trelby//src/trelby.py", line 4, in <module>
    import autocompletiondlg
  File "/usr/share/trelby//src/autocompletiondlg.py", line 1, in <module>
    import gutil
  File "/usr/share/trelby//src/gutil.py", line 2, in <module>
    import misc
  File "/usr/share/trelby//src/misc.py", line 5, in <module>
    import util
  File "/usr/share/trelby//src/util.py", line 20, in <module>
    import wx
ImportError: No module named wx

I wonder if there is any difference between wxgtk and wxwidgetsor what else might be the issue.

-- 
amc252 <[email-masked]>

---

From: Leo <[email-masked]>
Date: Thu, 4 Jun 2020 21:48:50 -0300

On Thu, 4 Jun 2020 17:36:39 -0700
amc252 <[email-masked]> wrote:

> Hello,
> I'm trying to run Trelby on Alpine. I have installed Trelby
> dependencies: python, wxgtk (which should rpovide wxwidgets,
> py3-wxpython, and py3-lxml. However, when I run Trelby from the
> terminal, I get the following error: alpine:~$ trelby Traceback (most
> recent call last): File "/usr/bin/trelby", line 8, in <module>
>     import trelby
>   File "/usr/share/trelby//src/autocompletiondlg.py", line 1, in
> <module> import gutil

Hello

I found no trelby package in Alpine Linux, but the error happens
because py3-wxpython package is not installed.

Regards
Leo