Subject: UEFI 32 bit

From: "Xavier B." <[email-masked]>
Date: Fri, 7 Aug 2020 10:52:29 +0200

Hi,

I have a machine (x86) which has 32-bit UEFI. I can be install debian and arch in it [https://hwswbits.blogspot.com/2015/03/getting-linux-on-minix-neo-z64.html] modifying installation script. Is alpine linux prepared for that case or I have to modify somehow the distro? Any hints?

Thanks in advance,
Xavier

---

From: PICCORO McKAY Lenz <[email-masked]>
Date: Fri, 7 Aug 2020 09:23:17 -0430

apart of the usage of winbvuntu.. the "bootia32.efi" must be compiled?

why not just install  alpine using chroot from the already installed linux
? less complicated in xtrange steps.. later you can try to change things..

i heard that 32bit UEFI bios are not common!

Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com

El vie., 7 de ago. de 2020 a la(s) 04:22, Xavier B. ([email-masked])
escribió:

> Hi,
>
> I have a machine (x86) which has 32-bit UEFI. I can be install debian and
> arch in it [
> https://hwswbits.blogspot.com/2015/03/getting-linux-on-minix-neo-z64.html]
> modifying installation script. Is alpine linux prepared for that case or I
> have to modify somehow the distro? Any hints?
>
> Thanks in advance,
> Xavier
>

---

From: "Marcus Rohrmoser" <[email-masked]>
Date: Tue, 11 Aug 2020 10:56:19 +0200

I'm having the a similar issue with my Asus x205ta notebook.

Currently I'm on xubuntu focal plus an additional partition to dual-boot alpine.

But I'm clueless
- which partition/directory to put the alpine boot image,
- how to tell grub about it,
- how to actually bootstrap alpine (lost in documentation).

I'm ok with keeping a xubuntu just to seed/update grub in long terms.

M

---

From: David Davies <[email-masked]>
Date: Tue, 11 Aug 2020 23:13:12 +0000

I've been able to get this working in the past with a Lenovo TV stick, which has a x64 processor with a 32 bit uefi.

I'm going from memory so sorry if might miss something, but you need to do the following:

  1.  Install Alpine as uefi using the setup-alpine script
  2.  Mount your new install to /mnt from the live envirnment
  3.  chroot into to /mnt
  4.  Inside the chroot, mount the EFI partition to /boot/efi
  5.  Delete everything inside /boot/efi
  6.  Copy this file (https://github.com/hirotakaster/baytail-bootia32.efi/blob/master/bootia32.efi) into /boot/efi/alpine
  7.  Create the file:   /boot/efi/alpine/startup.nsh
  8.  Put this line in startup.nsh:   bootia32.efi
  9.  Now install grub again, with these parameters:    grub-install --removable --no-nvram /dev/sda
  10. umount /boot/efi and exit the chroot
  11. umount /mnt and reboot

Again, I'm going from memory so there might be a mistake in the order or a step I've missed, but this should hopefully work.

________________________________
From: ~alpine/users <~alpine/[email-masked]> on behalf of Marcus Rohrmoser <[email-masked]>
Sent: Tuesday, 11 August 2020 6:56 PM
To: ~alpine/[email-masked]
Subject: Re: UEFI 32 bit

But I'm clueless

M

David Davies

National: 1300 854 292
www.cybersecure.com<http://www.cybersecure.com>

Australia's trusted cyber protection provider since 2003

---

From: Natanael Copa <[email-masked]>
Date: Fri, 7 Aug 2020 16:16:26 +0200

On Fri, 7 Aug 2020 10:52:29 +0200

> I have a machine (x86) which has 32-bit UEFI. I can be install debian and arch in it [https://hwswbits.blogspot.com/2015/03/getting-linux-on-minix-neo-z64.html] modifying installation script. Is al…

Short answer: I dont think its tested, but it is possible you could run it 32 bit.

Alternatively you could wget the 32bit grub package from 64bit alpine
and extract the gruia32.efi file and copy it to grubx64.efi similar to
what they mention in that article.

But basically, you are on your own here.

Please share if you make it work :)

-nc

---

From: "Xavier B." <[email-masked]>
Date: Sun, 9 Aug 2020 19:52:39 +0200

Thanks a lot. But if it's not tested, I will not make risk

On Fri, 7 Aug 2020 16:16:26 +0200