Subject: Re: upgrade from 3.12.3 to 3.13.0

From: David Restall <[email-masked]>
Date: Fri, 22 Jan 2021 09:55:09 +0000

Hi Dietmar,

>>>> ISOLINUX 6.04 4.04-pre1 Copyright (C) 1994-2015 H. Peter Anvin et
>>>> al boot:
>>>> /sbin/init not found in new root. Launching emergency recovery
     ^^^^^^^^^^^^^^^^^^^^^^

seems to be the main problem.  Have you checked that /sbin/init exists ?

When the system boots, it loads a file system from a compressed image
into memory and boots from that then hands over to the installed OS.
Check that you have /sbin/init in both places - not too sure what the
best way to check in your situation is but on my box I'd look at the
contents of /boot/initramfs-lts.  Use :

gzip -dc /boot/initramfs-lts | cpio -t | grep init

to see if the file is present.  Mine returns :

alpine:~# gzip -dc /boot/initramfs-lts | cpio -t | grep init
init
lib/modules/5.4.84-0-lts/kernel/drivers/scsi/initio.ko
246716 blocks

so shows that init is in / rather than /sbin.

Also check that it's in the uncompressed image on the usb stick.  Mount
the image using - again not too sure what your situation is :-

mount /dev/WHATEVER_YOUR_USB_ROOT_PARTION_IS /mnt
ls -al /mnt/sbin

should show the file.

If it's not there, cp it in and see if it boots :-)

There are LOTS of ways this can be sorted, the above is probably not the
best, quickest or easiest but it should give you some idea of a starting
point.  Apologies,  if you have already tried this and the above is a
complete load of rubbish :-)

Regards,

D
lists/alpine/users/2021-01-22.tx                               alpineusers
+----------------------------------------------------------------------------+
| Dave Restall, Computer Anorak, Geek, Cyclist, Radio Amateur G4FCU, Bodger  |
| Mob +44 (0) 7973 831245      Skype: dave.restall             Radio: G4FCU  |
| email : [email-masked]  - Anti-SocialMediaist -  Web : Not Ready Yet :-( |
+- QOTD ---------------------------------------------------------------------+
| The Hollywood tradition I like best is called "sucking up to the stars."   |
|         -- Johnny Carson                                                   |
+----------------------------------------------------------------------------+

> Hi Natanael,
> 
> thanks for your help, I was missing the lts (tried vanilla and virt).
> But unfortunately this doesn't change anything, it just takes 10 seconds =
> 
> longer.
> 
> Best
>    Dietmar
> 
> On 1/22/21 8:20 AM, Natanael Copa wrote:
> > On Thu, 21 Jan 2021 18:25:04 +0100
> > Dietmar Rieder <[email-masked]> wrote:
> >=20
> >> Hi,
> >>
> >> thanks for the suggestion. I'm not sure how to add this option?
> >=20
> > When you see the boot prompt "boot:"  you type: lts usbdelay=3D10
> >=20
> > -nc
> >=20
> >>
> >> Anyway, when the alpine is in the recovery shell ("/ #") I see that
> >> the USB stick /dev/sda is mounted. I also see the activity led
> >> flashing during the boot, so I guess the usb controller is
> >> initialized. I also see the # progress bar going to 100% (see [1]
> >> screenshot)
> >>
> >> I do not have such issues with older versions of Alpine.
> >>
> >> Best
> >>      Dietmar
> >>
> >> [1]:
> >> <https://drive.google.com/file/d/1mwY6iyx8sav_-Z4zcxnwSDobJljo8G9A/vie=
> w?usp=3Dsharing>
> >>
> >> On 1/21/21 5:15 PM, Natanael Copa wrote:
> >>> On Thu, 21 Jan 2021 14:02:55 +0100
> >>> Dietmar Rieder <[email-masked]> wrote:
> >>>   =20
> >>>> Hi,
> >>>>
> >>>> I'm trying to upgrade a diskless installation (config and apk
> >>>> cache on usb) from Alpine 3.12.3 to 3.13.0 but while booting the
> >>>> new ISO image I get the following error when the USB stick is
> >>>> inserted:
> >>>>
> >>>> --------------------------------------------------------------------=
> ------------------------------
> >>>> ISOLINUX 6.04 4.04-pre1 Copyright (C) 1994-2015 H. Peter Anvin et
> >>>> al boot:
> >>>> /sbin/init not found in new root. Launching emergency recovery
> >>>> shell Type exit to Continue boot.
> >>>> sh: can't access tty; job control turned off
> >>>> / #
> >>>> --------------------------------------------------------------------=
> ------------------------------
> >>>>
> >>>> When I boot the new ISO an empty USB stick all works fine and I can
> >>>> configure Alpine from scratch. However I'd like to upgrade and
> >>>> migrate my previous settings and packages as I used to do whenever
> >>>> I switched release.
> >>>>
> >>>> Is there any way to solve that problem?
> >>>
> >>> Does it boot if you add the boot option usbdelay=3D10?
> >>>
> >>> Might be that the usb controller needs more than a ssecond to
> >>> initialize.
> >>>>
> >>>> Thanks
> >>>>       Dietmar
> >>>>  =20
> >>>   =20
> >>
> >>
> >=20
> 
> 
> --=20
> _________________________________________
> D i e t m a r  R i e d e r, Mag.Dr.
> Innsbruck Medical University
> Biocenter - Institute of Bioinformatics
> Innrain 80, 6020 Innsbruck
> Phone: +43 512 9003 71402
> Fax: +43 512 9003 73100
> Email: [email-masked]
> Web:   http://www.icbi.at
> 
> 
> 
> --QvE63Fgt2rf4cxeY0PBFvt8Bu5amvWQAG--
> 
> --ZLwSYbv2Vcz3SOPdkaYurxAEL2E80oNVM
> Content-Type: application/pgp-signature; name="OpenPGP_signature.asc"
> Content-Description: OpenPGP digital signature
> Content-Disposition: attachment; filename="OpenPGP_signature"
> 
> -----BEGIN PGP SIGNATURE-----
> 
> wsD5BAABCAAjFiEETMNnW1mARfhGEq4RlZroVZ3BaicFAmAKhVsFAwAAAAAACgkQlZroVZ3Baidj
> KAv/dZP0QtzJ/CL9Hg9+dyJhsqhkg55IMRyXZUyFzO2h34olVmIRlPMD0GasTCZjkcSKswVdedJ6
> WCAVTRwDRlV62sImyIdIvaS2TrZCRT99YUfqM1GP9fsdn/Zcq2Q20CJ2j+dj8LtjyMQ/zR+mrgkI
> 9aDFheKVMLfIILG0u8uGo8A/DklE2FNvufBRv8gewzMEtRw1x66Fy/JoWa3Z26I2Gst/VrCBtn1n
> SOcQhHFR3gLhccQMcj80IQxgzP4X7CwzRBqBAmP8ESqYJKGIjv9UuFlRXIY58GGEwViWCECJd77D
> QCTfG31ZGumHNS3SFayWwVwObkwvUaIZ3SvVTPoWhguwAnmo/NcBuZ0cu9OtzU7lV48hsLSpzKAq
> p1qnlP0VWufBjUEqIUKXVdljZ3kJQXYQCwdlrsjCRzwz2RkvGZGcOffRHir3H1uyls49vSEnE3T9
> HB/gIZgV1jrYF5gK4N+FCo43mQIUZdDvV3lbkcQFU9bUbEiyArbHQPp3X2Lm
> =9my6
> -----END PGP SIGNATURE-----
> 
> --ZLwSYbv2Vcz3SOPdkaYurxAEL2E80oNVM--
>

---

From: Dietmar Rieder <[email-masked]>
Date: Sun, 31 Jan 2021 10:03:11 +0100

Hi David,

thanks for all your suggestions. However I was not able to get the 
upgrade to work. So I decided to start from scratch with 3.13.0 and 
manually "restored" my 3.12.3 configuration, it didn't take all to long 
after all.

Thanks again
   Dietmar

--