Subject: desktop freeze after upgrade

From: luciphercode <[email-masked]>
Date: Fri, 12 Feb 2021 16:14:06 -0800

Hello,

I have just installed Alpine and everything worked fine until I ugraded my system
to edge.
Now I can use the desktop as root, but it freezes if I lanuch startx as user.
I get the desktop, but the mouse is frozen and I cannot use any command.
the xorg error log shows errors like this:

[    53.446] (EE) xf86OpenSerial: Cannot open device /dev/input/event4
	Permission denied.
[    53.446] (II) event4: opening input device '/dev/input/event4' failed (Permission denied).
[    53.446] (II) event4  - failed to create input device '/dev/input/event4'.
[    53.446] (EE) libinput: Power Button: Failed to create a device for /dev/input/event4
[    53.446] (EE) PreInit returned 2 for "Power Button"
[    53.446] (II) UnloadModule: "libinput"
[    53.447] (II) config/udev: Adding input device Video Bus (/dev/input/event8)
[    53.447] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    53.447] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    53.447] (II) Using input driver 'libinput' for 'Video Bus'
[    53.447] (**) Video Bus: always reports core events
[    53.447] (**) Option "Device" "/dev/input/event8"
[    53.447] (**) Option "_source" "server/udev"

the entire xorg.0.log can be seen at:
https://pastebin.com/tYCJeGdU

I'm fairly new at Linux, can anyone help me troubleshoot the problem?

---

From: Paul Bredbury <[email-masked]>
Date: Sat, 13 Feb 2021 18:50:12 +0000

> [    53.446] (II) event4: opening input device '/dev/input/event4' failed (Permission denied).

$ ls -l /dev/input
crw-rw---- 1 root input 13, 68 Feb 13 12:12 event4

Are you in the "input" group?

---

From: luciphercode <[email-masked]>
Date: Sat, 13 Feb 2021 14:09:51 -0800

Paul Bredbury

> Are you in the "input" group?

Indeed I was not. I added my username to the "input" group and now it works (posting this from my Alpine).
I assume upgrading the system to edge modified something, since I wasn't in the "input" group before.
Thanks a lot for the prompt answer, I'm learning the ropes.