Subject: [edge] curl update?

From: Steffen Nurpmeso <[email-masked]>
Date: Thu, 21 Sep 2023 00:01:09 +0200

Hello!

Is there a reason curl is not updated to v8.3.0?  I had seen it
was tagged on the packages site last week already?
It is not that CVE alone, 'just that i do not understand the
reasoning.

  #?0|kent:curl.git$ git diff --stat curl-8_2_1..curl-8_3_0|tail -n1
  964 files changed, 14468 insertions(+), 12416 deletions(-)

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---

From: Konstantin Kulikov <[email-masked]>
Date: Thu, 21 Sep 2023 09:34:56 +0300

https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/51528

---

From: Steffen Nurpmeso <[email-masked]>
Date: Thu, 21 Sep 2023 19:26:14 +0200

Konstantin Kulikov wrote in
 <CAD+eXGQN=[email-masked]>:
 |https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/51528

I see.  Thanks.  I did not even think about looking there; If
i only look at https://pkgs.alpinelinux.org/packages and then
search.  I added a bookmark to gitlab.

--steffen
|

---

From: Natanael Copa <[email-masked]>
Date: Thu, 21 Sep 2023 08:39:10 +0200

On Thu, 21 Sep 2023 00:01:09 +0200

> It is not that CVE alone, 'just that i do not understand the

There is a test failing on arm32. We need to figure out why.

https://github.com/curl/curl/discussions/11882

-nc

---

From: Steffen Nurpmeso <[email-masked]>
Date: Thu, 21 Sep 2023 19:27:54 +0200

Natanael Copa wrote in
 <[email-masked]>:
 |On Thu, 21 Sep 2023 00:01:09 +0200
 |Steffen Nurpmeso <[email-masked]> wrote:
 |> Is there a reason curl is not updated to v8.3.0?  I had seen it
 |> was tagged on the packages site last week already?
 |> It is not that CVE alone, 'just that i do not understand the
 |> reasoning.
 |
 |There is a test failing on arm32. We need to figure out why.
 |
 |https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/51528
 |
 |https://github.com/curl/curl/discussions/11882

The trouble of packagers.
Thanks!

--steffen
|