Subject: dracut conundrum

From: Ian Smith <[email-masked]>
Date: Sun, 12 Apr 2026 12:55:11 +0100

NOTE: all machines are running Alpine 3.23.3

Today there was a Raspberry Pi kernel update.  I noticed the error below
during upgrade on two of my machines, but not the third one. I have not
noticed any problems after reboot on any of them, and all three machines
are running the new kernel.

Pi5/500:
Executing dracut-109-r0.trigger
* dracut-install: ERROR: installing '/bin/dash'
* dracut[E]: FAILED: /usr/lib/dracut/dracut-install -D
  /var/tmp/dracut.dOIUDZT/initramfs /bin/dash

Pi4 (upgraded "remotely" so I have a transcript!):
(1/6) Upgrading libcap2 (2.77-r0 -> 2.78-r0)
(2/6) Upgrading libssh (0.11.3-r0 -> 0.11.4-r0)
(3/6) Upgrading xdg-dbus-proxy (0.1.6-r0 -> 0.1.7-r0)
(4/6) Upgrading xdg-dbus-proxy-doc (0.1.6-r0 -> 0.1.7-r0)
(5/6) Upgrading linux-rpi (6.12.67-r0 -> 6.12.81-r0)
(6/6) Upgrading lyrebird (0.7.0-r4 -> 0.7.0-r5)
Executing busybox-1.37.0-r30.trigger
Executing kmod-34.2-r1.trigger
Executing mkinitfs-3.13.0-r0.trigger
* creating /boot/initramfs-rpi for 6.12.81-0-rpi
Executing mandoc-apropos-1.14.6-r14.trigger
Executing raspberrypi-bootloader-common-1.20251208-r0.trigger
* Configured kernel vmlinuz-rpi / initramfs-rpi
OK: 5433.6 MiB in 1649 packages

So, on the Pi4 the dracut trigger is not being run at all!  Is there a
serious dracut issue (it is reported as an ERROR, not a WARNING) on the
Pi5/500, or OTOH is there a problem with it not being run at all on the
PI4?

---

From: Konstantin Kulikov <[email-masked]>
Date: Sun, 12 Apr 2026 18:56:14 +0300

There is no reason to have both dracut and mkinitfs. Alpine uses the latter
by default. Check what your bootloader is loading and remove what's not
needed.

---

From: Ian Smith <[email-masked]>
Date: Sun, 12 Apr 2026 17:28:35 +0100

Thanks for your reply!

I was puzzled why I had dracut on the two more _recent_ machines, and I
finally remembered why.

It became apparent when I tried to install mkinitfs on one of the
erroring machines; there was a conflict between dash-binsh and
busybox-binsh!

So I tried removing dash-binsh, and that was what reminded
me:

$ doas apk del -s dash-binsh
( 1/34) Purging coreutils-doc (9.8-r1)
( 2/34) Purging dracut-doc (109-r0)
( 3/34) Purging dracut-bash-completion (109-r0)
( 4/34) Purging dracut (109-r0)
( 5/34) Purging dracut-modules-network (109-r0)
( 6/34) Purging networkmanager-cli (1.54.3-r0)
( 7/34) Purging networkmanager-doc (1.54.3-r0)
( 8/34) Purging networkmanager-bash-completion (1.54.3-r0)
( 9/34) Purging networkmanager-openrc (1.54.3-r0)
(10/34) Purging networkmanager (1.54.3-r0)
(11/34) Purging networkmanager-initrd-generator (1.54.3-r0)
(12/34) Purging dracut-modules (109-r0)
(13/34) Purging sed-doc (4.9-r2)
(14/34) Purging sed (4.9-r2)
(15/34) Purging dracut-core (109-r0)
(16/34) Purging grep-doc (3.12-r0)
(17/34) Purging grep (3.12-r0)
(18/34) Purging coreutils (9.8-r1)
(19/34) Purging coreutils-env (9.8-r1)
(20/34) Purging coreutils-fmt (9.8-r1)
(21/34) Purging coreutils-sha512sum (9.8-r1)
(22/34) Purging dash-binsh (0.5.13.1-r2)
(23/34) Purging dash-doc (0.5.13.1-r2)
(24/34) Purging dash (0.5.13.1-r2)
(25/34) Purging libndp-doc (1.9-r1)
(26/34) Purging libndp (1.9-r1)
(27/34) Purging libnm (1.54.3-r0)
(28/34) Installing busybox-binsh (1.37.0-r30)
(29/34) Installing kmod (34.2-r1)
(30/34) Installing kmod-doc (34.2-r1)
(31/34) Installing kmod-bash-completion (34.2-r1)
(32/34) Installing lddtree (1.27-r0)
(33/34) Installing mkinitfs (3.13.0-r0)
(34/34) Installing mkinitfs-doc (3.13.0-r0)
OK: 5426.3 MiB in 1924 packages

So, dracut was pulled in in a messy "upgrade" to dash-binsh.  I clearly
need to decide whether it is more important to cleanly install a new
kernel, or have ANSI colours in my own programs!

-- 
--

It's ME!