Subject: makeinitfs - Cross Compile

From: filip Mutterer <[email-masked]>
Date: Fri, 15 May 2026 19:08:31 +0200

Hi!

When doing cross compile on x86 for aarch64 can I just use the x86 to 
create the initramfs?

greetings

filip

---

From: Konstantin Kulikov <[email-masked]>
Date: Fri, 15 May 2026 20:55:50 +0000

You can use x86 mkinitfs binary, but you need to set basedir ("-b" flag) to
your aarch64 rootfs. And also "-c mkinitfs.conf" cuz it's not prefixed with
basedir last time I checked.