Subject: Alpine 3.23 with kernel 6.18 boot failed

From: 赵 唯轲 <[email-masked]>
Date: Fri, 9 Jan 2026 07:40:26 +0000

The device in use is a Mac with an M-series chip running macOS 26.3 beta.

Alpine Linux 3.23 for the ARM64 architecture fails to boot in certain virtualization environments, including VirtualBox 7.2.4 and VMware Fusion 25H2. Installed systems hang at "loading ramdisk," while booting from the ISO gets stuck at “booting Linux Lts” and does not proceed further.

However, the system boots successfully in UTM using both Apple Virtualization and QEMU modes.

---

From: Natanael Copa <[email-masked]>
Date: Fri, 9 Jan 2026 16:22:48 +0100

On Fri, 9 Jan 2026 07:40:26 +0000
赵 唯轲 <[email-masked]> wrote:

> Alpine Linux 3.23 for the ARM64 architecture fails to boot in certain
> virtualization environments, including VirtualBox 7.2.4 and VMware
> Fusion 25H2. Installed systems hang at "loading ramdisk," while
> booting from the ISO gets stuck at “booting Linux Lts” and does not
> proceed further.

Have you tried the alpine-virt image?
 
> Virtualization and QEMU modes.

I use qemu and lima and they work.

-nc