Subject: [alpine-user] FW: Alpine Linux 3.5.0

From: TASHA WENNER <[email-masked]>
Date: Wed, 15 Mar 2017 14:02:21 +0000

Good morning,
I am following up on my email below.  Any assistance you can provide would be greatly appreciated.

Thank you,
Tasha

Tasha Wenner
Compliance Specialist
Supply Chain

+1 720-202-6566   (cell phone)

From: TASHA WENNER
Sent: Friday, February 17, 2017 9:02 AM
To: [email-masked]' <[email-masked]>
Subject: Alpine Linux 3.5.0

Good morning,
I work for Raytheon, reviewing Freeware and Open Source Software to ensure we can/will comply with the requirements and restrictions of the licenses.  I recently had a request for Alpine Linux 3.5.0 and I am unable to determine what the license is for this product.  Could you please confirm that this is FOSS, and if so, what is the license that governs this software?  If you could provide the license terms, I would greatly appreciate it.

Thank you for your time and assistance.

Thank you,
Tasha

The IIS FOSS Team has a new email address!  Please email all FOSS questions and expedite requests to [email-masked]<mailto:[email-masked]>.  Happy FOSSing!

Tasha Wenner
Compliance Specialist
Supply Chain
Intelligence, Information and Services
Raytheon Company

+1 720-202-6566   (cell phone)
[email-masked]<mailto:[email-masked]>

---

From: Jean-Louis Fuchs <[email-masked]>
Date: Wed, 15 Mar 2017 16:39:42 +0100

Hi

> I am following up on my email below.  Any assistance you can provide would be greatly appreciated.

Alpine Linux is not a product it is a distribution. Here are all the
licenses listed per package:

https://pkgs.alpinelinux.org/packages

Contact your system engineers to find out which packages are installed.

Best,
    Jean-Lois

---

From: Natanael Copa <[email-masked]>
Date: Thu, 16 Mar 2017 08:10:06 +0100

Hi,

I can confirm that Alpine Linux is FOSS. Its a collection of different
software packages with different licenses. The core components and
their licenses are:

linux kernel:	GPLv2
musl libc:	MIT
busybox:	GPLv2
apk-tools:	GPLv2
openrc:		BSD-2

What else licenses that are involved depends on what components you
chose to install.

I did a quick search for all the licenses we have in "main" and "community" repositories:

ncopa-desktop:~/aports$ grep license= main/*/APKBUILD community/*/APKBUILD | sed -e 's/.*=//' -e 's/"//g' -e "s/'//g" | sort -u
 AGPL-3.0
AGPL
AGPL3
AGPL3+
AGPLv3
APACHE
APACHE2
APACHE2.0
AS IS
AS-IS
ASL 2.0
ASL 2.0 PSF
ASL-2.0
ASL-2.0 LGPL-2.1
ASL-2.0 custom
ASL2
Apache
Apache 2.0
Apache BSD
Apache-2
Apache-2.0
Artistic
Artistic 2.0
Artistic GPL
Artistic GPL2
Artistic-2
Artistic-2.0
BSD
BSD 
BSD  # Simplified http://opensource.org/licenses/BSD-2-Clause
BSD GPL
BSD GPL2
BSD ISC
BSD MIT
BSD ZPL
BSD and (LGPLv2 with exceptions or GPLv3 with exceptions) and GFDL
BSD and LGPLv2+
BSD and LGPLv2+ and GPLv2+ and Public Domain
BSD and MIT
BSD with advertising
BSD-0
BSD-2
BSD-3
BSD/GPL
Boost
CC
CC-3.0
CC-BY-SA
CC0 1.0
CCPL-Attribution-ShareAlike-2.5
CDDL
CDDL LGPL custom
CMake
CUSTOM
Custom
EPL
EPL GPL-2 LGPL-2.1 custom
Eclipse 1.0
GLPL2.1
GNU
GNU GPL v2
GPL
GPL Apache
GPL BSD
GPL FDL
GPL LGPL
GPL LGPL MIT
GPL LGPL MPL
GPL LGPL2+
GPL PerlArtistic
GPL custom
GPL custom:OFL
GPL or Artistic
GPL or Artistic 2
GPL v2
GPL v2 or later
GPL+
GPL+ and GPLv2+ and LGPLv2+
GPL+ or Artistic
GPL-2
GPL-2 GPL-3 LGPL-2.1
GPL-2 gSOAP
GPL/LGPL
GPL/LGPL/MIT
GPL2
GPL2 
GPL2 GPL2+ LGPL2+ BSD Public Domain
GPL2 GPL3+ LGPL2 BSD
GPL2 LGPL-2
GPL2 LGPL2
GPL2 LGPL2+
GPL2 LGPL2.1
GPL2 MIT BSD
GPL2 RSA-MD5 RSA-PKCS11 DES
GPL2 and Artistic
GPL2 with Classpath
GPL2+
GPL2+ ASL 2.0
GPL2+ BSD
GPL2+ LGPL2+
GPL2+ LGPL2+ MPL 1.1
GPL2+ MIT Public Domain
GPL2+ with OpenSSL exception
GPL2, LGPL2.1
GPL2.1
GPL2/GPL3
GPL3
GPL3 BSD
GPL3 LGPL
GPL3 LGPL3
GPL3+
GPL3+ BSD
GPLV2+
GPLv2
GPLv2 GPLv2+ LGPLv2+
GPLv2 and GPLv2+ and GPLv3 and MIT
GPLv2 and GPLv2+ and LGPLv2 and MIT
GPLv2 or Artistic
GPLv2 or CC-BY-SA
GPLv2+
GPLv2+ LGPLv2+
GPLv2+ and LGPLv2+
GPLv3
GPLv3 LGPL3
GPLv3+
GPLv3+ and (GPLv2+ or LGPLv3+)
Happy
IPL-1
ISC
ISC BSD
LGPL
LGPL 2.1
LGPL GPL
LGPL MPL
LGPL+
LGPL-2.1
LGPL2
LGPL2+
LGPL2+ BSD
LGPL2+ MPL 1.1
LGPL2+ MPL-1.1
LGPL2+ MPL1.1
LGPL2+ scowl
LGPL2, GPL2
LGPL2.1
LGPL2.1 BSD-2
LGPL2.1 CCBY-SA3.0
LGPL2.1+
LGPL3
LGPL3+
LGPL3+ BSD
LGPLv2
LGPLv2 GPLv2 MPLv1.1
LGPLv2 and MPLv1.1
LGPLv2 with exceptions or GPLv3 with exceptions
LGPLv2 with exceptions or GPLv3 with exceptions and GFDL
LGPLv2+
LGPLv2+ MIT
LGPLv2+ VSL
LGPLv2+ and GPLv2+ or BSD
LGPLv2+ or ASL 2.0
LGPLv2.1
LGPLv3
LGPLv3 MPL
LGPLv3+
LGPLv3+ or CC-BY-SA
LGPLv3+ or GPLv2+ or (LGPLv3+ and GPLv2+)
LGPLv3+ with exceptions
MIT
MIT BSD
MIT BSD GPL2+
MIT BSD ISC
MIT BSD public-domain
MIT LGPLv2+
MIT UCD
MIT and ASL 2.0 and BSD
MIT custom
MIT public-domain
MIT/X
MIT/X11
MPL
MPL 1.1
MPL 2.0
MPL 2.0 GPL2+
MPL GPL
MPL-1.1 GPL2 LGPL-2.1
MPL-2.0
MPL1.1+ GPLv2+ LGPLv2+
MPL2
MPL2.0
MPLv2
OFL
OFL-1.1
Other
PHP
PHP-3
PSF
Perl
Perl Artistic
Perl Artistic GPL
Perl Artistic, GPL
PerlArtistic
PerlArtistic GPL
Public Domain
Public Domain and MIT
PublicDomain
Python
Ruby
SixXS
TCL
Two-clause BSD
UOI-NCSA
Unknown
Unlicense
WTFPL
X11
ZLIB
ZPL
ZPL-2.1
ZPL2+
apache bsd
apache_2_0
artistic_1
as-is
bsd
custom
custom GPL2
custom ISC
custom:$pkgname
custom:BELL
custom:BSD
custom:GPL
custom:JasPer2.0
custom:XFREE86
custom:Xiph LGPL GPL FDL
custom:etpan
custom:icu
custom:sip
lgpl_2_1
mit
none
openssl
public-domain
public-domain BSD
unknown
unlicense
wxWidgets
zlib

Hope this helps!

-nc

On Wed, 15 Mar 2017 14:02:21 +0000

> [email-masked]<mailto:[email-masked]>

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---