Subject: some problem with alpine

From: Joe Sypniewski <[email-masked]>
Date: Thu, 31 Dec 2020 18:37:39 +0000 (UTC)

I've just downloaded (Extended 482MB) version of alpine hopping that X will be included. Installation went w/o the problem; however while running alpine I encounter some problems:- I cannot mount other than extX partition; many of my flash memories are originally formatted as FAT32 since this manufacturers original special formatting provides leveling feature. The "Extended" version may need other FS's implemented.- Even I have loaded full "Extended" version; I have ended up with the basic system that only included ssh and very few other features (and busybox). My computer has no connection to the internet and on the provided iso image I've found 482MB empty partition that I cannot mount (beside efi partition). I have my own deb depository that I can use, but busybox does not have full implementation; the busybox' dpkg is not compiled.
The question is: 
What is the proper way of using alpine w/o the network access?What is the difference between "Extended" and other version since "Extended" does not contain any other software?
I very much appreciate your help and continue to use alpine
BTW I like very much your concept.

---

From: [email-masked]
Date: Fri, 01 Jan 2021 03:55:39 GMT

December 31, 2020 12:37 PM, "Joe Sypniewski" <[email-masked]> wrote:

> What is the proper way of using alpine w/o the network access?

Alpine works fine without network access, just not for your use-case.

> What is the difference between "Extended" and other version since "Extended" does not contain any
> other software?

Extended just includes a few commonly used utilities. Alpine is 
very much a lego distribution - if you want a desktop environment,
you're going to have to build it yourself. Which will require some
way to get .apk files to your box - typically the internet. Though
you could download them and stick them on a flash drive or similar,
if internet access is not possible.