Subject: OpenVswitch OVN Geneve

From: filip Mutterer <[email-masked]>
Date: Mon, 11 May 2026 15:44:46 +0200

Hello!
What are my options to have the kernel Module Geneve on an ARM system?

Greetings

filip

---

From: Konstantin Kulikov <[email-masked]>
Date: Mon, 11 May 2026 20:34:00 +0300

Easiest would be to file an issue here
https://gitlab.alpinelinux.org/alpine/aports/-/issues
with request to add CONFIG_OPENVSWITCH_GENEVE=m I assume.

Alternatively you could try to send merge request yourself here
https://gitlab.alpinelinux.org/alpine/aports/-/blob/master/main/linux-lts/lts.aarch64.config
But kernel config needs to be more or less similar between arches and
stable/lts/virt I'm not sure what the procedure is.