Subject: Netbooting Alpine in data mode not mounting to /var after reboot

From: Magnie Mozios <[email-masked]>
Date: Tue, 8 Dec 2020 22:36:01 -0700

Hello!

I am netbooting Alpine on a Raspberry Pi and am trying to set up "data 
mode". However, after running setup-alpine/setup-disk and following the 
prompts and then running a reboot, it never mounts the disk to /var 
again and instead mounts it to /media/sda2 (even though it isn't in the 
/etc/fstab file).

Here are the steps I took specifically:

 1. ssh [email-masked]
 2. Plugin in SSD
 3. setup-alpine... entered various preferences up to setup-dsk
 4. At setup-disk:
    Available disks are:
       sda    (128.0 GB JMicron  Tech            )
    Which disk(s) would you like to use? (or '?' for help or 'none')
    [none] sda
    The following disk is selected:
       sda    (128.0 GB JMicron  Tech            )
    How would you like to use it? ('sys', 'data', 'lvm' or '?' for help)
    [?] data
    WARNING: The following disk(s) will be erased:
       sda    (128.0 GB JMicron  Tech            )
    WARNING: Erase the above disk(s) and continue? [y/N]: y
 5. Then I go through setup-lbu (set to 'none') and setup-apkcache
    ('/var/cache')
 6. lbu include /root # To save the .ssh/authorized_keys
 7. lbu package /var # Saves /var/nas01.apkovl.tar.gz
 8. reboot
 9. During reboot it mounts my SSD and automatically runs the
    nas01.apkovl.tar.gz
10. On completion of reboot...
11. /var/nas01.apkovl.tar.gz does not exist
12. /media/sda2/nas01.apkovl.tar.gz does exist, but /media/sda2 is not
    in /etc/fstab
13. When trying 'mount -avvv' I get the following message:
    mount: mount('/dev/sda2','/var','ext4',0x00008000,'(null)'):-1:
    Resource busy

Does anyone have any suggestions on how to have Alpine mount my SSD 
(data) drive to /var?

Thank you!

Magnie Mozios

---

From: Magnie Mozios <[email-masked]>
Date: Wed, 23 Dec 2020 22:06:48 -0700

So, turns out that the "defaults" option that the setup-disk provides in 
/etc/fstab is read-only. So changing "defaults" to "rw,relatime" solved 
my problem.

As part of my debugging, I also learn that you can mount to /var after 
boot by running "mount -o rw,remount /dev/sda2 /var".

Hope that helps someone else.

On 12/8/20 10:36 PM, Magnie Mozios wrote:
> mode". However, after running setup-alpine/setup-disk and following 
> the prompts and then running a reboot, it never mounts the disk to 
> /var again and instead mounts it to /media/sda2 (even though it isn't 
> in the /etc/fstab file).
>
>     How would you like to use it? ('sys', 'data', 'lvm' or '?' for
>     help) [?] data