Subject: Dbus fails to start

From: amc252 <[email-masked]>
Date: Fri, 10 Dec 2021 10:07:11 -0800

Hi,

I installed dbus and then added it using
#rc-update add dbus

Then reboot and checked:
# rc-status
Runlevel: default
 sshd                                  [  started  ]
 slim                                  [  started  ]
 dbus                                  [  stopped  ]
 udev-postmount                        [  started  ]
 crond                                 [  started  ]
 acpid                                 [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 sysfs                                 [  started  ]
 fsck                                  [  started  ]
 root                                  [  started  ]
 localmount                            [  started  ]
 udev-settle                           [  started  ]
Dynamic Runlevel: manual

If I try:
# rc-service dbus start
 * checkpath: owner `root:messagebus' not found
 * ERROR: dbus failed to start

What is missing or whar am I doing wrong?

---

From: amc252 <[email-masked]>
Date: Fri, 10 Dec 2021 17:16:36 -0800

Perke:
I'm not an Alpine user, but I wonder:  Does the "messagebus" group exist in /etc/group ?

Thanks, Perke.
Adding messagebus:x:104: to /etc/group solved the problem.
Since this happened on a fresh install, could it be a bug?

---

From: Parke <[email-masked]>
Date: Fri, 10 Dec 2021 17:40:56 -0800

> Parke wrote [offlist]

> Since this happened on a fresh install, could it be a bug?

I'd call it a bug!

---

From: Paul Bredbury <[email-masked]>
Date: Mon, 13 Dec 2021 11:30:23 +0000

> Since this happened on a fresh install, could it be a bug?

Is added in https://gitlab.alpinelinux.org/alpine/aports/-/blob/master/main/dbus/dbus.pre-install

... although I can't say I approve of it hiding and ignoring any errors.