Subject: Trouble editing image from downloads to output on serial terminal (fixed formatting)

From: Adam Pickering <[email-masked]>
Date: Mon, 16 Mar 2020 23:41:55 +0000

Hello,

My apologies for the previous message - I didn't notice the link about etiquette until it was too late. The message is pasted below.

First of all, thanks for alpine linux. It's great and my favourite distro!

I'm trying to install alpine linux on a pcengines apu2. Before SSH is configured, the only way to communicate with this device is via serial connection. This is a bit of a problem since the image I downloaded from the downloads page is not configured to do this in syslinux. I have tried mounting the image as a loop device and changing the config myself, it won't let me edit it, saying it is "write protected" when I mount it. Is there a reason why this is the case? Is there any way to remove the write protection?

Also FYI it looks like the wiki is down.

Thanks,
Adam Pickering

---

From: Florian Haas <[email-masked]>
Date: Tue, 17 Mar 2020 15:40:21 +0100

Hi Adam,

I assume you see the text from the bootloader in some serial console 
terminal until the kernel boots.  I used 'picocom /dev/ttyUSB0 –omap 
delbs –baud 115200', and when the boot prompt is displayed ('boot:'), I 
entered 'lts console=ttyS0,115200'.  This enables the serial console 
with the correct baud rate.  Be sure to also append this in your 
syslinux.cfg before rebooting, or else append the same parameter to the 
boot command line again.

I hope this helps.

Best regards,
Florian