Subject: [alpine-user] setup-alpine broken?

From: Thomas Samoht <[email-masked]>
Date: Thu, 31 Jan 2019 09:02:56 +0100

Hi,

as im on a search for a leightweight distribution
that has the following features

- (ncthv) busybox
- (ncthv) non glibc
- (must)  xvesa or xorg, with i3 and corresponding helpers
- (must)  full virtualization on processors who support this
          (virtual machines for windows or other linux distros
           for proprietary software that is not supported on Alpine)

(ncthv=nice to have)

I came along Alpine. But unfortunately, although I am
using *nix systems for 34 years, and linux since 92 ;)
I cannot view on my own, if Alpine does have these
features, as the installation (on virtualbox in this
case) is not possible.

Host Mint 19.1 64 bit, Virtualbox 5.2.18, 6GB RAM
2 processors assigned to Alpine, 128MB graphic card with acceleration
2GB RAM, 4GB disk (for the test)
Alpine version was: 3.9 extended, downloaded yesterday

Point 1:

setup-alpine runs fine, until after it has asked for
chronyd which i accepted. Then the setup stucks forever.
Parallel ttys do still work at that time. So whats wrong
with setup-alpine?

The other points, I want to understand:

2a. I am sure, xvesa is supported from xfce being listed
   on distrowatch for your distro. However, it is not clear
   which proprietary drivers (like for nvidia or amd graphics
   cards are supported). Neither of xvesa, xorg, nvidia, amd*
   is listed in the package search. Can you enlighten me?

2b. Are proprietary printer drivers supported (samsung, hp, etc),
    or just cups?

3. I also cannot find (=search) xfce in your package lists, although
   it was listed on distrowatch, while i can find openbox there. So
   which of the common window managers are supported?

4. From your point of view: Would there be any upcoming problems for me
   to compile the i3 wm sources (and the usual helper tools) on my own?

5. As I have mostly used virtualbox instead of xen, this is a Xen-newbie
   question, so forgive me, if I havent had the time to read all the
   documentation yet: I expect xen to be able to do exactly what
   virtualbox can do. 5a) Is that correct? 5b) Is direct device
   forwarding possible (network, usb devices, etc)? 5c) What about
   sound (onboard and usb sound cards)? As I read, Alpine uses
   alsa (which is nice in my point of view): What happens if the
   guest-os uses pulseaudio? Does this scenario work as expected
   with xen?

With kind regards,
Thomas

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Chloe Kudryavtsev <[email-masked]>
Date: Thu, 31 Jan 2019 11:42:20 -0500

> Hi,

Heya! Let me answer the ones I can.

> 1. setup-alpine runs fine, until after it has asked for

This sounds a bit like broken networking to me, but that should be 
timing out.
I suppose the question is on how long "forever" is.
Alternatively, this could be it getting stuck trying to get enough 
entropy (though again, I'm not sure if that's the case).
Can you try adding `random.trust_cpu=on` to the kernel command line on boot?

>     is listed in the package search. Can you enlighten me?

As far as I'm aware, proprietary drivers are not supported.
First off, we don't really like proprietary software, but on top of 
that, there's no way for us to patch them (e.g for them to work with musl).
You're free to try running the "official installer" off their websites 
though - just don't expect it to necessarily work.

> 2b. Are proprietary printer drivers supported (samsung, hp, etc),

Same as above, though do note that hp's drivers specifically aren't all 
that proprietary - hplip is available in-repo.

>     which of the common window managers are supported?

If you mean using pkgs.a.o[1], it only does exact matches.
However, it does support wildcards.
Xfce is available as "xfce4".
Next time, try adding some "*"s to your searches.
Alternatively, you can use `apk search` from inside of alpine - it uses 
substring matching.

>     to compile the i3 wm sources (and the usual helper tools) on my own?

Probably not, but you might miss out on musl-specific patches, such as 
i3wm-musl-glob-tilde.patch[2].

>     guest-os uses pulseaudio? Does this scenario work as expected

I have never used xen, but my understanding is that it goes further than 
virtualbox, and allows for paravirt.

Hopefully (at least some of) this helps!

[1]: https://pkgs.alpinelinux.org/
[2]: 
https://git.alpinelinux.org/aports/tree/community/i3wm/i3wm-musl-glob-tilde.patch

---