Subject: Re: [alpine-user] How to label mails (the gmail way) ?

From: Paul Zillmann <[email-masked]>
Date: Thu, 24 May 2018 13:06:03 +0200

Hello Franck

Am 23.05.2018 um 15:43 schrieb [email-masked]:
> Beginning a new job. I use the IMPA server of my company : it's a 
> outlook web app where nothing works really !... :D So I took a chance 
> to move to alpine.
> Can't really tell more as I am not expert in all this (IMAP/SMTP)...

You need to know what IMAP daemon you use. Is it Dovecot or Cyrus or 
Curier etc. pp.
> OK. If I got you well, it seems the behavior I am looking for is more 
> a IMAP server thing, not an alpine problem (my mistake - I believed it 
> was).
>
> Alpine can not create folders at IMAP server side and can't move mails 
> from/to IMAP server folders: correct ?
You can do that on every Linux if you configured the mailbox format to 
be "Maildir" -> every mail is a file on the filesystem
Configuring a mailsystem for internet usage requires some knowledge 
about DNS, DKIM signing etc.
I don't recommend you to run such a system (for a company) with your 
knowledge base.

You may take a look at Mailcow[1] - this is a finished configured 
mailsystem.

1: https://github.com/mailcow/mailcow-dockerized

Paul

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: <[email-masked]>
Date: Fri, 25 May 2018 12:25:56 +0200

On Thu, 24 May 2018, Paul Zillmann wrote:

>> Beginning a new job. I use the IMPA server of my company : it's a outlook 
>> web app where nothing works really !... :D So I took a chance to move to 
>> alpine.
> You need to know what IMAP daemon you use. Is it Dovecot or Cyrus or Curier 
> etc. pp.
>> OK. If I got you well, it seems the behavior I am looking for is more a 
>> IMAP server thing, not an alpine problem (my mistake - I believed it was).
>> 
> You can do that on every Linux if you configured the mailbox format to be 
> "Maildir" -> every mail is a file on the filesystem
> Configuring a mailsystem for internet usage requires some knowledge about 
> DNS, DKIM signing etc.

Didn't had yet time to go into details and to test.

Just to be OK on the headlines, you say that:
- if I go "S" + "L" + set non empty path (/home/user/mail) in the list
- IMAP will "initialize" mails from the server to the local
   /home/user/mail directory
- Then from alpine I can create a folder and move a mail into it
- Then (when I quit alpine ?) the folder and moved mail will be
   replicated on the IMAP server

Correct ?

> You may take a look at Mailcow[1] - this is a finished configured mailsystem.
>

Franck

---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Fri, 25 May 2018 14:54:28 +0200

Hello Franck.

<[email-masked]> wrote:
 |On Thu, 24 May 2018, Paul Zillmann wrote:
 |> Am 23.05.2018 um 15:43 schrieb [email-masked]:
 |>> Beginning a new job. I use the IMPA server of my company : it's \
 |>> a outlook 
 |>> web app where nothing works really !... :D So I took a chance to move to 
 |>> alpine.
 |>> Can't really tell more as I am not expert in all this (IMAP/SMTP)...
 ...
 |>> Alpine can not create folders at IMAP server side and can't move mails 
 |>> from/to IMAP server folders: correct ?

This is the mailing-list of the Alpine Linux distribution, not the
Alpine mail user agent program.  I do not know about Alpine MUA.

 ...
 |Didn't had yet time to go into details and to test.
 |
 |Just to be OK on the headlines, you say that:
 |- if I go "S" + "L" + set non empty path (/home/user/mail) in the list

But i would say it allows to freely assign key bindings as all
others do, so knowing about the actual functions would be an
improvement.

 |- IMAP will "initialize" mails from the server to the local
 |   /home/user/mail directory

I have no idea what you are talking about.
In general the IMAP server usually "is" the mailbox, and is
accessed, an internet connection provided, as if it is a local
mailbox.  MUAs download parts of the messages as you are looking
at them, some have local caches to keep that data around.

 |- Then from alpine I can create a folder and move a mail into it

If it can the former, you can simply access the IMAP mailbox as if
it would be a local folder.

 |- Then (when I quit alpine ?) the folder and moved mail will be
 |   replicated on the IMAP server

That is hard to believe, but like i have said, i do not know about
Alpine.  But automatic replication in between a regular local
mailbox and an IMAP mailbox somewhere else usually requires
special software, which (i would say) just compares folder
contents and performs synchronization, then.

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---