Subject: [alpine-user] virtualbox installation not persistent after alpine-setup

From: Alexander Abramidis <[email-masked]>
Date: Thu, 9 Aug 2018 22:45:37 +0200

Hi there,

I have installed Alpine in Oracle Virtualbox. After that I have run
setup-alpine and entered the following values (among others):
sda; sys;
So partitions are created.

Then I entered "reboot", but all my settings got lost, also root forgot my
provided password. I expected Alpine to save all my settings, but it did
not.
I found the tool "lbu", but there the manual says:
"All your modifications have already been directly written to your HDD." 

So what's wrong with it?

---

From: Ulf Volmer <[email-masked]>
Date: Thu, 9 Aug 2018 23:14:42 +0200

> provided password. I expected Alpine to save all my settings, but it did

i guess you are still booting from the iso image.
remove it from the VM or change the boot order.

best regards
Ulf

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Fungi4All <[email-masked]>
Date: Sat, 11 Aug 2018 17:54:56 +0000

> remove it from the VM or change the boot order.

Or hit F12 in the start and choose hard disk, usually choice #1
If something is still not working you can boot from the live and chroot into the mounted hd partition.
mount /dev/sda1 /mnt
chroot /mnt

then modify your installation

---

---

From: Alexander Abramidis <[email-masked]>
Date: Sun, 12 Aug 2018 11:10:10 +0200

thank you for the solution

---