Subject: [alpine-user] apk: BAD signature

From: Sebastian Wagner <[email-masked]>
Date: Wed, 6 Feb 2019 11:18:12 +0100

Hi,

I am using Alpine 3.9.0 and I get this error currently:

# apk upgrade
(1/2) Installing tini-static (0.18.0-r0)
ERROR: tini-static-0.18.0-r0: BAD signature
(2/2) Installing popt (1.16-r7)
ERROR: popt-1.16-r7: BAD signature
2 errors; 505 MiB in 131 packages

And the same for `apk fix` and `apk add/del` for any package. Does
someone have a clue how I can fix this?

Sebastian

-- 
// Sebastian Wagner <[email-masked]> - T: +43 1 5056416 7201
// CERT Austria - https://www.cert.at/
// Eine Initiative der nic.at GmbH - https://www.nic.at/
// Firmenbuchnummer 172568b, LG Salzburg

---

From: Sebastian Wagner <[email-masked]>
Date: Wed, 6 Feb 2019 11:36:37 +0100

Some suggested that this is a mirror issue off-list.

I was using the default ones http://dl-cdn.alpinelinux.org/alpine/.
Using http://dl-2.alpinelinux.org/alpine/ fixed the issue for me.

Sebastian