Subject: Alpine Linux Xen 4.13 libxl and bootloader error

From: Helmut Pohl <[email-masked]>
Date: Thu, 12 Mar 2020 17:14:53 +0100

Hey there,

i use Linux alpine-xen3 4.19.98-0-vanilla with 4 domU and all went fine.
After update from Alpine Linux Xen 3.11 with new release xen-4.13,
there are errors and the domu's don't start. I hope, you can help me.

Helmut

1. error:

xl create xen-fli4l.pv -c

Parsing config from xen-fli4l.pv
libxl: error: libxl_create.c:979:libxl__domain_config_setdefault:
passthrough not supported on this platform

domU has a passthrough networkcard 3com509 and is xen-pciback in dom0:

dmesg | grep pciback
[   33.923574] pciback 0000:05:00.0: seizing device
[   33.923943] xen_pciback: backend is vpci

domU cfg-file: cat xen-fli4l.pv

#  Kernel + memory size
#
bootloader  = '/usr/lib/xen/bin/pygrub'
#memory      = '256'
memory       = '512'
pci = ['0000:05:00.0']

#
#  Disk device(s).
#
disk        = [
                  'file:/img/xen-fli4l_64.img.1,xvda1,w',
                  'file:/img/xen-fli4l_64.img.2,xvda2,w',
              ]

#
#  Hostname
#
name        = 'xen-fli4l'

#
#  Networking
#

vif         =   [
                'bridge=br0,vifname=vif-fli4l-0,mac=00:16:3E:29:74:55',
#               'bridge=br1,vifname=vif-fli4l-1,mac=00:16:2A:CF:BA:DD'
                ]

#
#  Behaviour
#
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'#

2. error:

xl create eis64-cloud.pv -c

Parsing config from eis64-cloud.pv
Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst

Traceback (most recent call last):

                               File "/usr/lib/xen/bin/pygrub", line 931,
in <module>
                                                        raise
RuntimeError("Unable to find partition containing kernel")
               RuntimeError: Unable to find partition containing kernel

libxl: error: libxl_bootloader.c:648:bootloader_finished: Domain
7:bootloader failed - consult logfile /var/log/xen/bootloader.7.log

                         libxl: error:
libxl_exec.c:117:libxl_report_child_exitstatus: bootloader [3759] exited
with error status 1

                          libxl: error:
libxl_create.c:1420:domcreate_rebuild_done: Domain 7:cannot (re-)build
domain: -3

                libxl: error: libxl_domain.c:1177:libxl__destroy_domid:
Domain 7:Non-existant domain
libxl: error: libxl_domain.c:1131:domain_destroy_callback: Domain
7:Unable to destroy guest
libxl: error: libxl_domain.c:1058:domain_destroy_cb: Domain
7:Destruction of domain failed

cat /var/log/xen/bootloader.7.log

Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst
Traceback (most recent call last):
  File "/usr/lib/xen/bin/pygrub", line 931, in <module>
    raise RuntimeError("Unable to find partition containing kernel")
RuntimeError: Unable to find partition containing kernel

domU cfg-file: cat eis64-cloud.pv

######
# Konfiguration  eis64-cloud
#
name = "eis64-cloud"
console="hvc0"
bootloader = "pygrub"
memory = 2048
shadow_memory='8'
acpi=1
apic=1
vcpus = 1
maxvcpus = 1
cpus='all'
keymap='de'
boot = 'c'
root = "/dev/xvda3 ro"
disk = [
       'file:/img/eis64-cloud.img,xvda,w'
       ]
vif=['mac=00:16:3e:29:b0:9c, bridge=br0, vifname=eis64-cloud']
on_xend_start="start"
on_xend_stop="shutdown"
on_reboot="restart"
on_poweroff="destroy"
on_crash="preserve"

xl info

host                   : alpine-xen3
release                : 4.19.98-0-vanilla
version                : #1-Alpine SMP Thu Jan 23 10:26:30 UTC 2020
machine                : x86_64
nr_cpus                : 4
max_cpu_id             : 3
nr_nodes               : 1
cores_per_socket       : 4
threads_per_core       : 1
cpu_mhz                : 2400.095
hw_caps                :
bfebfbff:0000e3bd:20100800:00000001:00000000:00000000:00000000:00000000
virt_caps              : pv hvm shadow
total_memory           : 8191
free_memory            : 6046
sharing_freed_memory   : 0
sharing_used_memory    : 0
outstanding_claims     : 0
free_cpus              : 0
xen_major              : 4
xen_minor              : 13
xen_extra              : .0
xen_version            : 4.13.0
xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32
hvm-3.0-x86_32p hvm-3.0-x86_64
xen_scheduler          : credit2
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          :
xen_commandline        : dom0_mem=2G,max:2G dom0_max_vcpus=2 dom0_vcpus_pin
cc_compiler            : gcc (Alpine 9.2.0) 9.2.0
cc_compile_by          : buildozer
cc_compile_domain      :
cc_compile_date        : Wed Dec 18 18:47:34 UTC 2019
build_id               : 6680e62e8530a4265011a4eebef426fd8c6d6597
xend_config_format     : 4

lspci -k
03:00.0 Class 0101: 11ab:6121 pata_marvell
00:1f.2 Class 0106: 8086:3a22 ahci
00:1c.0 Class 0604: 8086:3a40 pcieport
05:02.0 Class 0280: 1397:2bd0
00:1a.1 Class 0c03: 8086:3a38 uhci_hcd
00:1f.0 Class 0601: 8086:3a16 lpc_ich
02:00.0 Class 0200: 1969:1026 ATL1E
00:01.0 Class 0604: 8086:2e21 pcieport
00:1d.1 Class 0c03: 8086:3a35 uhci_hcd
00:1c.5 Class 0604: 8086:3a4a pcieport
01:00.0 Class 0300: 10de:016a nouveau
00:1b.0 Class 0403: 8086:3a3e snd_hda_intel
05:01.0 Class 0100: 9005:0080 aic7xxx
00:1e.0 Class 0604: 8086:244e
00:1f.3 Class 0c05: 8086:3a30
00:00.0 Class 0600: 8086:2e20
00:1a.2 Class 0c03: 8086:3a39 uhci_hcd
00:1d.2 Class 0c03: 8086:3a36 uhci_hcd
00:1a.0 Class 0c03: 8086:3a37 uhci_hcd
05:00.0 Class 0200: 10b7:9050 pciback
00:1d.0 Class 0c03: 8086:3a34 uhci_hcd
05:03.0 Class 0c00: 11c1:5811 firewire_ohci
00:1a.7 Class 0c03: 8086:3a3c ehci-pci
00:1c.4 Class 0604: 8086:3a48 pcieport
00:1d.7 Class 0c03: 8086:3a3a ehci-pci

 xenstore-ls -fp

/tool = ""   (n0)
/tool/xenstored = ""   (n0)
/local = ""   (n0)
/local/domain = ""   (n0)
/local/domain/0 = ""   (n0)
/local/domain/0/control = ""   (n0)
/local/domain/0/control/feature-poweroff = "1"   (n0)
/local/domain/0/control/feature-reboot = "1"   (n0)
/local/domain/0/control/feature-suspend = "1"   (n0)
/local/domain/0/name = "Domain-0"   (n0)
/local/domain/0/domid = "0"   (n0)
/local/domain/0/device-model = ""   (n0)
/local/domain/0/device-model/0 = ""   (n0)
/local/domain/0/device-model/0/backends = ""   (n0)
/local/domain/0/device-model/0/backends/console = ""   (n0,n0)
/local/domain/0/device-model/0/backends/vkbd = ""   (n0,n0)
/local/domain/0/device-model/0/backends/vfb = ""   (n0,n0)
/local/domain/0/device-model/0/backends/qnic = ""   (n0,n0)
/local/domain/0/device-model/0/state = "running"   (n0)
/vm = ""   (n0)
/libxl = ""   (n0)

 xl dmesg
 Xen 4.13.0
(XEN) Xen version 4.13.0 (buildozer@) (gcc (Alpine 9.2.0) 9.2.0) debug=n
 Wed Dec 18 18:47:34 UTC 2019
(XEN) Latest ChangeSet:
(XEN) Bootloader: SYSLINUX 6.04 6.04-pre1
(XEN) Command line: dom0_mem=2G,max:2G dom0_max_vcpus=2 dom0_vcpus_pin
(XEN) Xen image load base address: 0
(XEN) Video information:
(XEN)  VGA is text mode 80x25, font 8x16
(XEN)  VBE/DDC methods: none; EDID transfer time: 0 seconds
(XEN)  EDID info not retrieved because no DDC retrieval method detected
(XEN) Disc information:
(XEN)  Found 7 MBR signatures
(XEN)  Found 6 EDD information structures
(XEN) Xen-e820 RAM map:
(XEN)  0000000000000000 - 000000000009cc00 (usable)
(XEN)  000000000009cc00 - 00000000000a0000 (reserved)
(XEN)  00000000000e4000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 00000000cff70000 (usable)
(XEN)  00000000cff70000 - 00000000cff7e000 (ACPI data)
(XEN)  00000000cff7e000 - 00000000cffd0000 (ACPI NVS)
(XEN)  00000000cffd0000 - 00000000d0000000 (reserved)
(XEN)  00000000fee00000 - 00000000fee01000 (reserved)
(XEN)  00000000fff00000 - 0000000100000000 (reserved)
(XEN)  0000000100000000 - 0000000230000000 (usable)
(XEN) New Xen image base address: 0xcf800000
(XEN) ACPI: RSDP 000FAFF0, 0014 (r0 ACPIAM)
(XEN) ACPI: RSDT CFF70000, 0040 (r1 A_M_I_ OEMRSDT   3001011 MSFT       97)
(XEN) ACPI: FACP CFF70200, 0084 (r2 A_M_I_ OEMFACP   3001011 MSFT       97)
(XEN) ACPI: DSDT CFF70440, 9720 (r1  A0993 A0993001        1 INTL 20060113)
(XEN) ACPI: FACS CFF7E000, 0040
(XEN) ACPI: APIC CFF70390, 006C (r1 A_M_I_ OEMAPIC   3001011 MSFT       97)
(XEN) ACPI: MCFG CFF70400, 003C (r1 A_M_I_ OEMMCFG   3001011 MSFT       97)
(XEN) ACPI: OEMB CFF7E040, 0089 (r1 A_M_I_ AMI_OEM   3001011 MSFT       97)
(XEN) ACPI: HPET CFF79B60, 0038 (r1 A_M_I_ OEMHPET   3001011 MSFT       97)
(XEN) ACPI: OSFR CFF79BA0, 00B0 (r1 A_M_I_ OEMOSFR   3001011 MSFT       97)
(XEN) ACPI: SSDT CFF7EAD0, 0A7C (r1 DpgPmm    CpuPm       12 INTL 20060113)
(XEN) System RAM: 8191MB (8387632kB)
(XEN) Domain heap initialised
(XEN) IOAPIC[0]: apic_id 4, version 32, address 0xfec00000, GSI 0-23
(XEN) Enabling APIC mode:  Flat.  Using 1 I/O APICs
(XEN) PCI: Not using MCFG for segment 0000 bus 00-ff
(XEN) Unrecognised CPU model 0xf - assuming not reptpoline safe
(XEN) Unrecognised CPU model 0xf - assuming vulnerable to LazyFPU
(XEN) Unrecognised CPU model 0xf - assuming vulnerable to L1TF
(XEN) Unrecognised CPU model 0xf - assuming vulnerable to MDS
(XEN) Speculative mitigation facilities:
(XEN)   Hardware features:
(XEN)   Compiled-in support: INDIRECT_THUNK SHADOW_PAGING
(XEN)   Xen settings: BTI-Thunk RETPOLINE, SPEC_CTRL: No, Other:
BRANCH_HARDEN
(XEN)   L1TF: believed vulnerable, maxphysaddr L1D 36, CPUID 36, Safe
address c00000000
(XEN)   Support for HVM VMs: RSB EAGER_FPU
(XEN)   Support for PV VMs: RSB EAGER_FPU
(XEN)   XPTI (64-bit PV only): Dom0 enabled, DomU enabled (without PCID)
(XEN)   PV L1TF shadowing: Dom0 disabled, DomU enabled
(XEN) Using scheduler: SMP Credit Scheduler rev2 (credit2)
(XEN) Initializing Credit2 scheduler
(XEN) Platform timer is 14.318MHz HPET
(XEN) Detected 2400.095 MHz processor.
(XEN) I/O virtualisation disabled
(XEN) ENABLING IO-APIC IRQs
(XEN)  -> Using new ACK method
(XEN) Allocated console ring of 16 KiB.
(XEN) VMX: Supported advanced features:
(XEN)  - APIC MMIO access virtualisation
(XEN)  - APIC TPR shadow
(XEN)  - Virtual NMI
(XEN)  - MSR direct-access bitmap
(XEN) HVM: ASIDs disabled.
(XEN) HVM: VMX enabled
(XEN) HVM: Hardware Assisted Paging (HAP) not detected
(XEN) Brought up 4 CPUs
(XEN) Dom0 has maximum 408 PIRQs
(XEN)  Xen  kernel: 64-bit, lsb, compat32
(XEN)  Dom0 kernel: 64-bit, PAE, lsb, paddr 0x1000000 -> 0x242c000
(XEN) PHYSICAL MEMORY ARRANGEMENT:
(XEN)  Dom0 alloc.:   000000021c000000->0000000220000000 (487217 pages
to be allocated)
(XEN)  Init. ramdisk: 000000022af31000->000000022fffffa4
(XEN) VIRTUAL MEMORY ARRANGEMENT:
(XEN)  Loaded kernel: ffffffff81000000->ffffffff8242c000
(XEN)  Init. ramdisk: 0000000000000000->0000000000000000
(XEN)  Phys-Mach map: 0000008000000000->0000008000400000
(XEN)  Start info:    ffffffff8242c000->ffffffff8242c4b8
(XEN)  Xenstore ring: 0000000000000000->0000000000000000
(XEN)  Console ring:  0000000000000000->0000000000000000
(XEN)  Page tables:   ffffffff8242d000->ffffffff82444000
(XEN)  Boot stack:    ffffffff82444000->ffffffff82445000
(XEN)  TOTAL:         ffffffff80000000->ffffffff82800000
(XEN)  ENTRY ADDRESS: ffffffff820b8180
(XEN) Dom0 has maximum 2 VCPUs
(XEN) Initial low memory virq threshold set at 0x4000 pages.
(XEN) Scrubbing Free RAM in background
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) Xen is relinquishing VGA console.
(XEN) *** Serial input to DOM0 (type 'CTRL-a' three times to switch input)
(XEN) Freed 540kB init memory

dmesg
[    5.138271] hub 4-0:1.0: 2 ports detected
[    5.138561] xen: registering gsi 18 triggering 0 polarity 1
[    5.138564] Already setup the GSI :18
[    5.138593] uhci_hcd 0000:00:1a.2: UHCI Host Controller
[    5.138599] uhci_hcd 0000:00:1a.2: new USB bus registered, assigned
bus number 5
[    5.138644] uhci_hcd 0000:00:1a.2: irq 18, io base 0x0000bc00
[    5.138781] usb usb5: New USB device found, idVendor=1d6b,
idProduct=0001, bcdDevice= 4.19
[    5.138783] usb usb5: New USB device strings: Mfr=3, Product=2,
SerialNumber=1
[    5.138785] usb usb5: Product: UHCI Host Controller
[    5.138786] usb usb5: Manufacturer: Linux 4.19.98-0-vanilla uhci_hcd
[    5.138788] usb usb5: SerialNumber: 0000:00:1a.2
[    5.138967] hub 5-0:1.0: USB hub found
[    5.139001] hub 5-0:1.0: 2 ports detected
[    5.139302] xen: registering gsi 23 triggering 0 polarity 1
[    5.139305] Already setup the GSI :23
[    5.139334] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[    5.139341] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned
bus number 6
[    5.139387] uhci_hcd 0000:00:1d.0: irq 23, io base 0x0000b080
[    5.139609] usb usb6: New USB device found, idVendor=1d6b,
idProduct=0001, bcdDevice= 4.19
[    5.139611] usb usb6: New USB device strings: Mfr=3, Product=2,
SerialNumber=1
[    5.139613] usb usb6: Product: UHCI Host Controller
[    5.139615] usb usb6: Manufacturer: Linux 4.19.98-0-vanilla uhci_hcd
[    5.139616] usb usb6: SerialNumber: 0000:00:1d.0
[    5.139774] hub 6-0:1.0: USB hub found
[    5.139791] hub 6-0:1.0: 2 ports detected
[    5.140079] xen: registering gsi 19 triggering 0 polarity 1
[    5.140082] Already setup the GSI :19
[    5.140110] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[    5.140117] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned
bus number 7
[    5.140183] uhci_hcd 0000:00:1d.1: irq 19, io base 0x0000b400
[    5.140381] usb usb7: New USB device found, idVendor=1d6b,
idProduct=0001, bcdDevice= 4.19
[    5.140383] usb usb7: New USB device strings: Mfr=3, Product=2,
SerialNumber=1
[    5.140385] usb usb7: Product: UHCI Host Controller
[    5.140387] usb usb7: Manufacturer: Linux 4.19.98-0-vanilla uhci_hcd
[    5.140388] usb usb7: SerialNumber: 0000:00:1d.1
[    5.140554] hub 7-0:1.0: USB hub found
[    5.140571] hub 7-0:1.0: 2 ports detected
[    5.140868] xen: registering gsi 18 triggering 0 polarity 1
[    5.140871] Already setup the GSI :18
[    5.140900] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[    5.140906] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned
bus number 8
[    5.140951] uhci_hcd 0000:00:1d.2: irq 18, io base 0x0000b480
[    5.141093] usb usb8: New USB device found, idVendor=1d6b,
idProduct=0001, bcdDevice= 4.19
[    5.141095] usb usb8: New USB device strings: Mfr=3, Product=2,
SerialNumber=1
[    5.141096] usb usb8: Product: UHCI Host Controller
[    5.141098] usb usb8: Manufacturer: Linux 4.19.98-0-vanilla uhci_hcd
[    5.141099] usb usb8: SerialNumber: 0000:00:1d.2
[    5.141285] hub 8-0:1.0: USB hub found
[    5.141302] hub 8-0:1.0: 2 ports detected
[    5.147396] Linux agpgart interface v0.103
[    5.202420] xen: registering gsi 16 triggering 0 polarity 1
[    5.202426] Already setup the GSI :16
[    5.203266] xen: registering gsi 16 triggering 0 polarity 1
[    5.203269] Already setup the GSI :16
[    5.204011] nouveau 0000:01:00.0: NVIDIA NV44 (044a00b2)
[    5.401445] nouveau 0000:01:00.0: bios: version 05.44.02.67.01
[    5.406784] nouveau 0000:01:00.0: fb: 128 MiB DDR2
[    5.457759] [TTM] Zone  kernel: Available graphics memory: 986014 kiB
[    5.457761] [TTM] Initializing pool allocator
[    5.457766] [TTM] Initializing DMA pool allocator
[    5.457780] nouveau 0000:01:00.0: DRM: VRAM: 124 MiB
[    5.457782] nouveau 0000:01:00.0: DRM: GART: 512 MiB
[    5.457785] nouveau 0000:01:00.0: DRM: TMDS table version 1.1
[    5.457787] nouveau 0000:01:00.0: DRM: DCB version 3.0
[    5.457789] nouveau 0000:01:00.0: DRM: DCB outp 00: 01000300 00000028
[    5.457791] nouveau 0000:01:00.0: DRM: DCB outp 01: 02011310 00000028
[    5.457793] nouveau 0000:01:00.0: DRM: DCB outp 02: 01011312 00000000
[    5.457795] nouveau 0000:01:00.0: DRM: DCB outp 03: 020223f1 0080c020
[    5.457797] nouveau 0000:01:00.0: DRM: DCB conn 00: 0000
[    5.457799] nouveau 0000:01:00.0: DRM: DCB conn 01: 1130
[    5.457800] nouveau 0000:01:00.0: DRM: DCB conn 02: 0210
[    5.462601] nouveau 0000:01:00.0: DRM: Saving VGA fonts
[    5.517172] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    5.517173] [drm] Driver supports precise vblank timestamp query.
[    5.520165] nouveau 0000:01:00.0: DRM: MM: using M2MF for buffer copies
[    5.520176] nouveau 0000:01:00.0: DRM: Setting dpms mode 3 on TV
encoder (output 3)
[    5.630031] nouveau 0000:01:00.0: DRM: allocated 1024x768 fb: 0x9000,
bo (____ptrval____)
[    5.631236] fbcon: nouveaufb (fb0) is primary device
[    5.760080] Console: switching to colour frame buffer device 128x48
[    5.869545] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[    5.885691] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0
on minor 0
[    5.891169] xen: registering gsi 17 triggering 0 polarity 1
[    5.891175] Already setup the GSI :17
[   21.145702] scsi host8: Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER,
Rev 7.0
[   21.145702]         <Adaptec 29160 Ultra160 SCSI adapter>
[   21.145702]         aic7892: Ultra160 Wide Channel A, SCSI Id=7,
32/253 SCBs
[   21.145702]
[   24.994650] xen: registering gsi 18 triggering 0 polarity 1
[   24.994654] Already setup the GSI :18
[   24.994667] ACPI Warning: SystemIO range
0x0000000000000400-0x000000000000041F conflicts with OpRegion
0x0000000000000400-0x000000000000040F (\SMRG) (20180810/utaddress-213)
[   24.994673] ACPI: If an ACPI driver is available for this device, you
should use it instead of the native driver
[   25.540899] random: crng init done
[   26.592306] raid6: sse2x1   gen()  3773 MB/s
[   26.648968] raid6: sse2x1   xor()  3779 MB/s
[   26.705636] raid6: sse2x2   gen()  4528 MB/s
[   26.762298] raid6: sse2x2   xor()  4806 MB/s
[   26.818969] raid6: sse2x4   gen()  7154 MB/s
[   26.875633] raid6: sse2x4   xor()  5574 MB/s
[   26.875634] raid6: using algorithm sse2x4 gen() 7154 MB/s
[   26.875635] raid6: .... xor() 5574 MB/s, rmw enabled
[   26.875636] raid6: using ssse3x2 recovery algorithm
[   26.875999] async_tx: api initialized (async)
[   26.876366] xor: measuring software checksum speed
[   26.908963]    prefetch64-sse:  9548.400 MB/sec
[   26.942297]    generic_sse:  8445.600 MB/sec
[   26.942298] xor: using function: prefetch64-sse (9548.400 MB/sec)
[   27.011993] md/raid:md0: device sdf1 operational as raid disk 5
[   27.011995] md/raid:md0: device sde1 operational as raid disk 4
[   27.011996] md/raid:md0: device sdd1 operational as raid disk 3
[   27.011998] md/raid:md0: device sdc1 operational as raid disk 2
[   27.011999] md/raid:md0: device sdb1 operational as raid disk 1
[   27.012000] md/raid:md0: device sda1 operational as raid disk 0
[   27.012716] md/raid:md0: raid level 5 active with 6 out of 6 devices,
algorithm 2
[   27.012758] md0: detected capacity change from 0 to 10001973248000
[   28.129598] EXT4-fs (sdg3): mounted filesystem with ordered data
mode. Opts: (null)
[   31.875501] xen: registering gsi 19 triggering 0 polarity 1
[   31.875507] Already setup the GSI :19
[   31.932377] firewire_ohci 0000:05:03.0: added OHCI v1.0 device as
card 0, 8 IR + 8 IT contexts, quirks 0x0
[   32.055512] xen: registering gsi 17 triggering 0 polarity 1
[   32.055516] Already setup the GSI :17
[   32.186257] ACPI Warning: SystemIO range
0x0000000000000828-0x000000000000082F conflicts with OpRegion
0x0000000000000800-0x000000000000084F (\PMRG) (20180810/utaddress-213)
[   32.186264] ACPI: If an ACPI driver is available for this device, you
should use it instead of the native driver
[   32.186270] ACPI Warning: SystemIO range
0x0000000000000530-0x000000000000053F conflicts with OpRegion
0x0000000000000500-0x000000000000053F (\GPS0) (20180810/utaddress-213)
[   32.186274] ACPI: If an ACPI driver is available for this device, you
should use it instead of the native driver
[   32.186275] ACPI Warning: SystemIO range
0x0000000000000500-0x000000000000052F conflicts with OpRegion
0x0000000000000500-0x000000000000053F (\GPS0) (20180810/utaddress-213)
[   32.186279] ACPI: If an ACPI driver is available for this device, you
should use it instead of the native driver
[   32.186279] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   32.416236] iTCO_vendor_support: vendor-support=0
[   32.417500] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11
[   32.417548] iTCO_wdt: Found a ICH10R TCO device (Version=2,
TCOBASE=0x0860)
[   32.417693] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[   32.455816] firewire_core 0000:05:03.0: created device fw0: GUID
001e8c00019097f5, S400
[   32.626431] xen: registering gsi 22 triggering 0 polarity 1
[   32.626464] xen: --> pirq=22 -> irq=22 (gsi=22)
[   32.675911] input: PC Speaker as /devices/platform/pcspkr/input/input3
[   32.778631] snd_hda_codec_realtek hdaudioC0D0: autoconfig for
ALC1200: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[   32.778634] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0
(0x0/0x0/0x0/0x0/0x0)
[   32.778636] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1
(0x1b/0x0/0x0/0x0/0x0)
[   32.778637] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   32.778639] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e
[   32.778640] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   32.778642] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[   32.778644] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[   32.778646] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[   32.813230] input: HDA Intel Front Mic as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input4
[   32.813323] input: HDA Intel Rear Mic as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input5
[   32.813409] input: HDA Intel Line as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input6
[   32.813495] input: HDA Intel Line Out Front as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input7
[   32.813585] input: HDA Intel Line Out Surround as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input8
[   32.813672] input: HDA Intel Line Out CLFE as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input9
[   32.813760] input: HDA Intel Line Out Side as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[   32.813848] input: HDA Intel Front Headphone as
/devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[   33.590097] NET: Registered protocol family 17
[   33.723209] NET: Registered protocol family 10
[   33.729184] Segment Routing with IPv6
[   33.923574] pciback 0000:05:00.0: seizing device
[   33.923734] xen: registering gsi 16 triggering 0 polarity 1
[   33.923738] Already setup the GSI :16
[   33.923943] xen_pciback: backend is vpci
[   33.941080] xen_wdt xen_wdt: initialized (timeout=60s, nowayout=0)
[   34.014057] tun: Universal TUN/TAP device driver, 1.6
[   34.798363] EXT4-fs (sdg3): re-mounted. Opts: (null)
[   35.038940] Adding 4194300k swap on /dev/sdg2.  Priority:-2 extents:1
across:4194300k
[   35.302320] EXT4-fs (sdg1): mounted filesystem with ordered data
mode. Opts: data=ordered
[   36.554466] bridge: filtering via arp/ip/ip6tables is no longer
available by default. Update your scripts to load br_netfilter if you
need this.
[   36.557357] br0: port 1(eth0) entered blocking state
[   36.557359] br0: port 1(eth0) entered disabled state
[   36.557511] device eth0 entered promiscuous mode
[   36.560571] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   36.560669] ATL1E 0000:02:00.0 eth0: NIC Link is Up <1000 Mbps Full
Duplex>
[   36.560680] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   36.569488] br0: port 1(eth0) entered blocking state
[   36.569490] br0: port 1(eth0) entered forwarding state
[   36.569526] IPv6: ADDRCONF(NETDEV_UP): br0: link is not ready
[   37.572338] IPv6: ADDRCONF(NETDEV_CHANGE): br0: link becomes ready
[   38.138165] xen:xen_evtchn: Event-channel device installed
[  480.835878] br0: port 2(vif5.0) entered blocking state
[  480.835881] br0: port 2(vif5.0) entered disabled state
[  480.835963] device vif5.0 entered promiscuous mode
[  480.838251] IPv6: ADDRCONF(NETDEV_UP): vif5.0: link is not ready
[  481.291818] Bridge firewalling registered
[  482.370393] xen-blkback: backend/vbd/5/51712: using 1 queues,
protocol 2 (x86_32-abi)
[  483.447011] vif vif-5-0 vif5.0: Guest Rx ready
[  483.447148] IPv6: ADDRCONF(NETDEV_CHANGE): vif5.0: link becomes ready
[  483.447181] br0: port 2(vif5.0) entered blocking state
[  483.447184] br0: port 2(vif5.0) entered forwarding state
[  628.915674] br0: port 2(vif5.0) entered disabled state
[  628.941388] br0: port 2(vif5.0) entered disabled state
[  628.941552] device vif5.0 left promiscuous mode
[  628.941560] br0: port 2(vif5.0) entered disabled state

---

From: Natanael Copa <[email-masked]>
Date: Fri, 13 Mar 2020 12:24:29 +0100

On Thu, 12 Mar 2020 17:14:53 +0100

> passthrough not supported on this platform

Can you try use linux-lts 5.4.y kernel instead of linux-vanilla kernel
for the dom0?

-nc

---

From: Helmut Pohl <[email-masked]>
Date: Fri, 13 Mar 2020 17:29:33 +0100

Hello Natanael,

> Can you try use linux-lts 5.4.y kernel instead of linux-vanilla kernel

yes, i add linux-lts and with kernel 5.4.12-1-lts there are the same
error's.

I think, i go back to alpine-linux 3.10. Do you have a idea, how can i
do it?

Are any other idea's fpr the problem in Xen 4.13 ?

best regards
Helmut